11

I have a problem with malware apps. Looks like some app called "Native" installed itself, and created a shortcut for itself, all without my permission. After that happened, I have pop-up ads every time I unlock my screen.

I have 2 security apps: Avast and 360 security. Neither of them can find anything wrong on my phone.

Because this new app "Native" uses such a common word as its name, I cannot find anything about it on the Internet, and I don't see anything called "Native" when I browse in the "Settings"->"Applications" menus.

So I am stuck with ads popping up every time I unlock the screen. What may be the possible solution?

  • I'm suspecting app called "com.android.ap.provider". But i'm not sure. it may be some default android app. – Ivan Kartofanov Sep 10 '15 at 10:03
  • I run that "Native" app, it showed one of the pop up ads i usually get, and then a blank screen with "Hello world" on it. After i closed the app, its shortcut dissapeared, and i still have those ads poping up. Antivirus software i have installed cannot detect anything. – Ivan Kartofanov Sep 10 '15 at 10:50
  • I am facing very similar advertisement issue on my swipe tablet. I keep getting a security permission notification which says HD player wants to get location information. I block it. But when I go into the list of installed apps there is no app named HD player. But when I see the list of all currently running app then title of one of the windows says HD Player. – RBT Nov 6 '16 at 4:05

11 Answers 11

6

Android 4 & 5

Android 4/5 recents to app info

  1. When the advertisement shows up, press the app switch button to display the recents menu (if the advertisement is full-screen and cover your soft buttons, swiping down from the top of the screen will make it appear).
  2. It will show the name of the app displaying the advertisement.
  3. From there, long press on the app and chose "app info"
  4. Uninstall the app.

Android 6

For Android 6 the process is similar, however the recents menu looks a bit different. In this step you now have to long press the app icon in the title bar:

Android 6 recents to app info

Android 7

For Android 7 the process is similar, however the recents menu looks a bit different. In this step you now have to long press the app icon then an info icon appears in the title bar that opens the settigs dialog of the app the screen belongs to:

Android 7 recents to app info

3

You could use Ad network scanner & detector .
It shows the app list which shows ads and such.
screenshot
This app hasn't been updated since two years

EDIT:
AD Block Notification lists all the installed packages and allows to block ads from specified packages
Screenshot 2

Or Block This! which blocks in-app ads and browser ads.

  • This app is not updated since May 15, 2013. I guess its AD definitions might be quite outdated... – That Brazilian Guy Sep 21 '15 at 1:35
  • @ThatBrazilianGuy Thank you for letting me know.Its true but this solution is for people who cannot be bothered with doing all those steps just to find out what are the apps shows, instead app shows all the apps that shows ads. – Manubhargav Sep 21 '15 at 1:42
  • 1
    All links broken. – NVZ Jan 19 '18 at 13:03
1

You can go into the setting>apps and then swipe to the left. Then look through the list and look for an app that is on but you do not recognize and has no google in it's package name.

1

Go to settings then click security, click device administrators there's an app checked there but doesnt have any name. Disable it. Then go to apps. Click the blank thingy above the first app with a name (ex. Android system webview) then uninstall it.

  • indeed, my kid had a blank application name listed. Removing it solved it. Thanks! – Klaas van Gend Oct 15 '17 at 16:38
0

Install an app from play store. The name is malwarebytes anti-malware. Do a full scan of device which takes time. It might show your device is infected with adware. Try deleting it. In some casesthe program which introduced the adware into the device might have enabled itself as an device administrator. Disable it and delete the adware.

Hope this helps☺☺

0

Screenshot
Click to Enlarge

  • Just go to settings -> apps.
  • Then u will spot any app without a name "as u see mine up" or that can't be deleted and it's new to you.
  • Mark it in the box that u see. Then click on the option button above. And disable it.
  • After that go back to the app and uninstall or delete it. I'm sure that the pop-up page won't come back
0

I had the same problem, but I managed to get rid of it. There was an application com.file-1 in data/app, didn't show anywhere except for lucky patcher, a blank space with "nothing to patch here", I saw the path in App info, tried to delete it in root browser but it came back. I finally uninstalled it in Titanium Backup, nothing else worked. Hope it helps

0

In addition to the answer by @king:

That actually seemed to work. Photos are post removal. Just to a walkthrough.

Once you're in the Lock screen sec/device admin, there's going to be one slot under the one from android that just shows the tick on the right but blank on the left. Untick that. There should be a prompt concerning administration rights. Deactivate that bad boy!

screenshot screenshot screenshot
(click images for larger variants)

Then go to apps manager. Once there look for any empty slots or rows on your apps list. On the photo i gave, there was once a row right before the app named "Adblock". You wont see it at first glance but its there. Just an empty row. Just to be sure, tap on all the apps you have on there until you notice the empty row. Tap on it and uninstall.

screenshot

So far it's been 20 minutes since i did it and no pop up screen window. Yet. As opposed to before where one pops up every time I come out of screen lock.

0

enter image description here

As you can see, I had a similar problem. It tool me 2 days but finally got the sucker. Mine was caused by this app called "android utility". It was so common that i overlooked it. Deleted many apps and couldnt find a solution.

Solution is similar to what the brazilian guy showed. For mine, i let the pop up run. Clicked on that little "i" at the corner of the pop up and it ran the app. The moment the app was identified, i uninstalled the app.

-1

there is a pirticular app which is white in colour.so in apps also you won't find any icon.beside it inly text appears.so make sure to get rid of that

-3

i have a simple solution for this problem...the ads appears because of an app which is invisible to us means we can't see that app in apps menu...so here is the solution.. Go to settings >lock screen and security>device administarion there you will see an app with no name is allowed for the device administration remove the tick from that app....this will not solve the problem there is more work to do. 😂😂 Now go to settings>app ... The invisible app will be in downloaded or maybe in running app on the first number look carefully.. Even I didn't saw the app first time.... You are all set now just click the app and softly touch the uninstall button, as i said touch the uninstall button softly. 😂😝😀😛👍👍👍👏👏👏...and done there will be no more ads.... If you don't understand what i have written above, you can send mail on sharmahainhum@gmail.com.
And if you think i am funny please vote me....

  • 1
    Please at least be somewhat serious. Remove the useless emojis and wording, and of course your contact details (to prevent spams heading your way). Also, it's a bad idea to just ask for votes... – Andy Yan Oct 18 '16 at 8:18

Not the answer you're looking for? Browse other questions tagged or ask your own question.