1

I downloaded this app called 'Photo Editor' (pink logo with letters 'fx' on it) on my HTC Desire 510, I went to uninstall it, but it won't let me do this. Other apps still let me download it. I have tried doing it in settings, google play store, second home screen menu, in the app itself, and none will let me uninstall it. I can't find the app in the play store, it's as if it's deliberately not letting me uninstall it. It takes up 30MB, which is a pain seeing as though my phone can only hold a small amount of data. I have been researching what to do but no one seems to have the same issue. Can anyone help me please? Thanks in advance.

6
  • Did the app downloaded additional data after installing ? Sep 11, 2015 at 7:30
  • 1. How did you install the app? 2. It's true that the HTC Desire 510 ships with only 8 GB of built-in flash memory. But you can insert a MicroSD card of up to 128 GB. Have you already inserted a card? Sep 11, 2015 at 7:32
  • What do you mean when you say you can't uninstall the app? What happens when you go to Settings > Apps and try to uninstall the app from there? Sep 11, 2015 at 8:32
  • 2
    Have you checked if that app registered as "device admin"? If so, unregister it (removing it from device admins; you can find this in Settings › Security › Device Administrators). An app registered as device admin can block its uninstallation. And avoid that app in the future: a photo admin has no reason for being device admin. If it requests such, I'd count that as indication for malicious intend.
    – Izzy
    Sep 11, 2015 at 8:41
  • Your phone needs to be rooted for you to be able to get rid of apps preinstalled. But here you say you have downloaded the app later. Have you tried clearing the device cache from recovery and then tried this? Jan 15, 2019 at 8:44

1 Answer 1

0

It's a pre-installed app from HTC you might be updated from play store . If your phone is rooted then you can uninstall that app

1
  • 1
    OP has literally specified that they have "downloaded" the app. This answer is, in my opinion quite invalid. Feb 22, 2021 at 3:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .