1

I have an old phone (LG Optimus V) running Android 2.2.1. I recently took it out and would like to download some apps on it. It automatically updated Android Market to Google Play by itself, but for some reason, it wouldn't let me download anything at all.

I keep getting two errors:

  1. Google Talk authentication failed

  2. Error retrieving information from server. [RPC:S-7:AEC-0 4SL6-CLLI-5VT2I]

I have tried everything:

  1. Clearing all data for Google Play and Google Services Framework

  2. Uninstalling updates for Google Play

  3. Restarting the phone

  4. Resetting the phone to default factory settings

  5. Creating a new Google account

I'm still getting the two errors above, and I can't download anything. Is there anything else I can try to resolve this problem?

  • 1
    If you are rooted, you could flash a gapps package. Sounds like you have a wrong version that updated to your LG – HasH_BrowN Sep 18 '15 at 17:55
  • @HasH_BrowN That fixed it, although flashing the gapps package also installed a whole bunch of bloatware that slowed down my phone a lot. I've rooted it, so I went ahead and deleted Facebook and Twitter and other stuff I probably won't use in my lifetime. – Illyasviel Dec 31 '15 at 16:02
  • you can also download the gapps package from teamandroiders.com/google-apps-gapps-for-android-roms. Scroll down to Android 2.2.1, then click on which zip file you want. The tiny is only 7.9 mb. – HasH_BrowN Jan 11 '16 at 5:13
1

Information pulled from http://wikitechsolutions.com/1222/error-while-retrieving-information-from-server-rpc-s-3-aec-and-rpc-7-aec-0

Method 1: Level: Easy

  • First we have to remove our Google account settings on this device. Go to: Settings > Accounts > Google > Delete Account.

  • Then, we will: Settings> Applications > All> Downloads > delete data.

  • Settings> Applications > All> Play Store> delete data.

  • Settings> Apps > All> Google Services Framework > delete data.

  • We turn off the device. Turn it on again.

  • Settings> Accounts> Add Account

If not then try

Method 2

Please read carefully. If the download does not work from the device, you'll have to download it to your PC. Then copy it to the device, using the USB cable to a folder on the external memory (microSD).

The Facebook app is the one most commonly generating this error, so we will focus on that. If needed, changing app files can be applied to almost any application that is giving you this problem.

Facebook version 3.8 is what we want :

Download Facebook 3.8 APK

How to get downloaded APK files to update through Google Play Store

  1. Enable installation from Unknown Sources
    • Settings> Security> and check the box for Unknown Sources option
  2. Locate the APK file you downloaded using a file manager.
  3. Open and install the APK file.
    • If installed version is newer than the downloaded APK, uninstall it & reboot, then continue.
  4. Open the application and login into Facebook with your username and password.
  5. Close the application and reboot.
  6. Open the Play Store & check for updates.
  7. Remove the check from step # 1, for added security.
0

I had an old Motorola Droid that I was trying to use the same way, ran into same problem. My phone is longer on the Verizon network, I think this was the source of the problems.

Tried lots of the stuff listed. Here is what finally worked for me. I suspect there may be a way to succeed without resetting your phone and loosing all of your installed apps/settings.

  • Reset the phone by going to Settings -> Privacy -> Factory data reset (don't "Backup my data")

  • Here is where these instructions differ from everywhere else after a reset:

    1. When the phone reboots, skip the activation step. (Because this phone can no longer be on the carrier's data or mobile phone network, as you probably have a newer phone using the same number, and if not, you still do not plan to activate it, this will be a Wi-Fi/bluetooth only phone)
    2. When it wants you to register with an existing google/facebook etc. account or create a new account using google, decline. We will come back to that. This stupid thing has not bothered to get on a wi-fi network yet, how can it possibly link to an account?
    3. Skip through the tutorial etc. until you get to the desktop screen.
    4. Go into settings, and enable airplane mode. This will prevent it from trying to use the mobile data network for any part of the account linkup.

      • Settings -> Wireless & network settings -> Airplane mode (before you do that, you may want to disable Mobile Data) Settings -> Mobile network Settings -> Data enabled

      • Now you can attach the phone to a google account. When I succeeded, I was using a google account I had created on the phone 10 minutes earlier before the last reset. (My phone wouldn't let me delete the original account without doing a factory reset.) I don't know if you can attach your phone to the original account you used when the phone was active, and have this method work.

    5. I then went into Settings -> Accounts & sync settings and disabled Auto-sync, and then added my new google account.

    6. I then went to Market, and was able to download the app I wanted. (Note that the original name for the Google App store was called Market, not Google Play. If it offers to update to Google Play, I recommend not doing that, unless you have to to download a newer app.

BTW, I didn't record it, so I don't know what the phone's versions were before the original reset, its currently Android 2.2.3, Kernel 2.6.32.9-g68eef5 android-build@apa26#1 build number FRK76. I rooted one of my old Droids, don't remember if this was that one.

Not the answer you're looking for? Browse other questions tagged or ask your own question.