The following message keeps appearing on my Samsung Galaxy S4 phone screen about every three seconds

"Unfortunately, Google Play Services has stopped".

Is it actually a virus or it is a problem with the Google Play Service? I have tried disabling the Google Play Service but the message keeps appearing. I have Norton Mobile running on my phone to pick up on viruses and to alert me to any possible security issues and also Lookout. They haven't picked up anything. Does anyone have any suggestions?

  • Did Norton ever report a virus to you? If so, it's time to drop it: there are no viruses on Android (malware yes, but no viruses). Try uninstalling the updates to Play Services, that often helps in such cases (sometimes updates have trouble; they get reinstalled after you removed them, and that time maybe cleaner, so don't worry about that).
    – Izzy
    Commented Sep 12, 2015 at 16:11
  • No Norton didn't report a virus to me. Commented Sep 12, 2015 at 16:31
  • I doubt it ever will, for the given reasons. Anti-virus apps are discussed controversely – they often cause more issues than they solve. Don't ever rely on them alone. They have their "uses", granted – but never more than a piece of a whole concept. // But back to your issue: Have you tried uninstalling updates? Did that help? As I wrote (and you can find that for many Google-app issues listed e.g. in our google-play-store tag-wiki), this is often recommended as possible solution.
    – Izzy
    Commented Sep 12, 2015 at 16:41
  • This helped me: Settings - Accounts - Google, remove the account and add it again. Commented Oct 1, 2016 at 8:05

6 Answers 6


Solution 1 – Update Google Play Services to the latest version. You can download from here. You may be getting an error because you have a very outdated version or the one you have is having a conflict/bug with the current Android version in your phone.

(source: teamandroid.com)

Solution 2 – Clear the Google Play Services cache. The Google Play Services app in your phone acts like a framework for all the Google and Google Play apps installed in your phone. You can try cleaning up its cache and see if that would fix the issue. This worked with one of our team members! Read these quick and easy steps:

Go to Settings > Apps.
Scroll to All apps and then scroll down to “Google Play Services” app.
Open the app details and tap on the “Force stop” (see "Force stop is disabled" below) button.
Then, tap on the “Clear cache” button.

Solution 3 - Uninstall the updates of "Google Play Services".

As in solution 2, go to Settings > Apps.
Scroll to All apps and then scroll down to the “Google Play Services” app.
Open the app details and:

  1. Tap on the “Force stop” (see "Force stop is disabled" below) button
  2. Tap on the "Disable" button
  3. Tap on the three dots at the top right and select: "Uninstall updates"
  4. Once the uninstallation is completed, tap on the "Enable" button

Solution 4 – Clear the Google Services Framework cache. The Google Services Framework system app on your Android device stores information and helps your phone sync with Google servers — and keeps your Google Play Services up and running. This could be one of the reasons why you are not able to connect to Google servers using the app and keep getting the error message. Read these quick and easy steps:

Go to Settings > Apps.
Scroll to All apps and then scroll down to “Google Services Framework” app.
Open the app details and tap on the “Force stop” button.
Then, tap on the “Clear cache” button.

Solution 5 – Check your Internet connection. Maybe your WiFi network is blocking any of the IP addresses that Google uses. You can also try switching the WiFi on or off on your phone — same with mobile data.

Solution 6 – This goes without saying, but maybe a simple reboot of your Android phone/tablet could fix the problem.

Solution 7 – I hate to say this, but in the end, you might just want to install a custom ROM that is stable with no bugs.

Force stop is disabled If either the "Disable" or the "Force Stop" buttons are disabled then:

  1. Go to SettingsDevice admin apps
  2. Deactivate the following apps if they are listed:
    • Find My Device
    • Google Play

(example on Android 8.0.0, Samsung Experience 9.0.0)

Note: Please, keep in mind that you may have to experiment with what apps you deactivate.

Your device admin apps list may differ. For example, you may have more or entirely different apps.

I have found that disabling the above two apps was enough for me to disable and force stop "Google Play services".

  • 1
    I'm not sure which version to download Commented Sep 12, 2015 at 16:30
  • 3
    Ashrith, Play Services auto-update themselves. No need to download some experimental "new version" – especially not if you already have issues with the one installed, and especially not from a place where you can't tell if it's safe. Clearing cache is a good point I've missed in my comment on the question itself, however.
    – Izzy
    Commented Sep 12, 2015 at 16:44
  • 5
    I fixed this issue by clearing the Data for Google Play Services, rather than just the Cache as mentioned in this answer.
    – user140820
    Commented Dec 10, 2015 at 14:58
  • I updated to the latest (public, official) versions of the OS and Play Services using the Samsung Smart Switch software, connecting from my laptop to the phone via USB. See method 4 at this link: geeksquad.co.uk/articles/… Commented Nov 21, 2016 at 13:59
  • I had this problem due to a conflict between my custom ROM (Katkiss) and the latest versions of Google Play Services. The solution was to revert to the factory version of Play Services, install the last version known to work with the ROM, then create some folders to prevent Play Services auto-updating to a bad version. I used these instructions for the detail: forum.xda-developers.com/eee-pad-transformer/general/… The same should work with other ROMs/devices, but you'll need to work out which version of Play Services you need.
    – JRI
    Commented Apr 15, 2017 at 18:22

Here is the way to fix this issue: go to APKMirror, find the last Google Play service, then download and install it. That's it. If you are having any problem then just go to the Settings → Applications → All → Google Play Store → then Uninstall Updates.


I've experienced this problem also and I found out the cause of it. So when you access any Google stuff the Google Play Services are used right.

Okay, that means that each time you play around any app using those services, it s going to require your device to be awake and/or keep the device awake. For some time I have used the Privacy Guard to make a restriction for this behavior i.e. to stop the apps from keeping my phone awake, even though it's locked/asleep.

So I went to the Privacy Guard and set the setting to "Ask every time" and what do you know, it started popping like crazy.

In conclusion: when you need to use the Google Play Services - set the permission for it to "Allowed", if you don't need it - that's when you want to stop it from draining your battery like crazy, then set it to "Denied".

  • Would be useful to actually explain the steps you take, or maybe the fact that you are referring to a third party app...
    – glace
    Commented Aug 12, 2021 at 21:26

After some searching, I found this solution from Google Play Help (archived) and that's how I solved the problem.

  1. Go to Settings -> Lock screen and security -> Other security settings -> Device Administrators (in your version it may vary slightly)
  2. Uncheck "Find My Device"
  3. Go to Settings -> Apps -> Google Play Services
  4. Tap the vertical ellipsis (3 vertical dots) at the top right -> Uninstall updates
  5. Go to Settings -> Apps -> Google Play
  6. Tap the vertical ellipsis (3 vertical dots) at the top right -> Uninstall updates
  7. Restart phone

At this point, the message "Google Play services keeps stopping" was gone. You may try now to still do

  1. Open one of the Google apps (in my case Google Maps)
  2. It complains that "Google Play services" is outdated, click the popup to update it again.
  • 1
    This is the only recipe that worked for me. Switching off "Find my device" was key.
    – Ilya Popov
    Commented Jul 24, 2020 at 17:01

The problem is in the updates. I fixed this problem by uninstalling updates from the Google Play Services app. All my Google apps started working. I went back in and reinstalled the update and it stopped working again so that tells me it's in the update.

Go to Settings - Apps - Google Play Services. Do a force stop on the app, and clear cache and data. Check and see if your Google apps are working. If you reinstall the update, it may stop working again.

  • This worked for me! I have no idea why this has been downvoted! Commented Oct 23, 2017 at 5:42

I've been having wakelock issues for the past week (OnePlus One) and today narrowed it down to googleplayservices. After some searching and reading, I went into Privacy Guard and turned permissions off for "Wake up" and "Keep Awake". My handset was again able to go to sleep after the set 15 seconds, but then that "Unfortunately, Google Play Services has stopped" error started popping up every 3 seconds in an endless loop.

I didn't connect the dots until this thread (hours later). Turned each back on separately to confirm. It's the "keep awake" that was the culpit. They're both on again, and I assume my phone will again have insomnia until whatever is wrong with the last update gets fixed.

I assume that googleplayservices needs to keep checking for something and preventing it from keeping the phone awake was causing the error loop. Maddening, but I can say from experience that that looping error is far worse than having to manually turn off the screen!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .