The following message keeps appearing on my Samsung Galaxy S4 phone screen about every three seconds

"Unfortunately, Google Play Services has stopped".

Is it actually a virus or it is a problem with the Google Play Service? I have tried disabling the Google Play Service but the message keeps appearing. I have Norton Mobile running on my phone to pick up on viruses and to alert me to any possible security issues and also Lookout. They haven't picked up anything. Does anyone have any suggestions?

  • Did Norton ever report a virus to you? If so, it's time to drop it: there are no viruses on Android (malware yes, but no viruses). Try uninstalling the updates to Play Services, that often helps in such cases (sometimes updates have trouble; they get reinstalled after you removed them, and that time maybe cleaner, so don't worry about that). – Izzy Sep 12 '15 at 16:11
  • No Norton didn't report a virus to me. – LingLing6985 Sep 12 '15 at 16:31
  • I doubt it ever will, for the given reasons. Anti-virus apps are discussed controversely – they often cause more issues than they solve. Don't ever rely on them alone. They have their "uses", granted – but never more than a piece of a whole concept. // But back to your issue: Have you tried uninstalling updates? Did that help? As I wrote (and you can find that for many Google-app issues listed e.g. in our google-play-store tag-wiki), this is often recommended as possible solution. – Izzy Sep 12 '15 at 16:41
  • This helped me: Settings - Accounts - Google, remove the account and add it again. – Alexey Solonets Oct 1 '16 at 8:05

Solution 1 – Update Google Play Services to the latest version. You can download from here. You may be getting an error because you have a very outdated version or the one you have is having a conflict/bug with the current Android version in your phone.

Solution 2 – Clear the Google Play Services cache. The Google Play Services app in your phone acts like a framework for all the Google and Google Play apps installed in your phone. You can try cleaning up its cache and see if that would fix the issue. This worked with one of our team members! Read these quick and easy steps :

Go to Settings > Apps.
Scroll to All apps and then scroll down to “Google Play Services” app.
Open the app details and tap on the “Force stop” button.
Then, tap on the “Clear cache” button.

Solution 3 – Clear the Google Services Framework cache. The Google Services Framework system app on your Android device stores information and helps your phone sync with Google servers — and keeps your Google Play Services up and running. This could be one of the reasons why you are not able to connect to Google servers using the app and keep getting the error message. Read these quick and easy steps :

Go to Settings > Apps.
Scroll to All apps and then scroll down to “Google Services Framework” app.
Open the app details and tap on the “Force stop” button.
Then, tap on the “Clear cache” button.

Solution 4 – Check your Internet connection. May be your WiFi network is blocking any of the IP addresses that Google use. You can also try switching the WiFi on or off on your phone — same with mobile data.

Solution 5 – This goes without saying, but may be a simple reboot of your Android phone/tablet could fix the problem.

Solution 6 – I hate to say this, but in the end, you might just want to install a custom ROM that is stable with no bugs.

  • I'm not sure which version to download – LingLing6985 Sep 12 '15 at 16:30
  • 2
    Ashrith, Play Services auto-update themselves. No need to download some experimental "new version" – especially not if you already have issues with the one installed, and especially not from a place where you can't tell if it's safe. Clearing cache is a good point I've missed in my comment on the question itself, however. – Izzy Sep 12 '15 at 16:44
  • 4
    I fixed this issue by clearing the Data for Google Play Services, rather than just the Cache as mentioned in this answer. – user140820 Dec 10 '15 at 14:58
  • 1
    Could I please propose Solution 7 - Revert the Google Play Services app to factory default version and the update. Worked for me to resolve this issue. To do this go Setting -> Apps -> All -> Google Play Services -> Disable -> Revert to Factory. Then once all the app complain they cant work with the old version, update the version. – David Waters Mar 9 '16 at 7:56
  • I updated to the latest (public, official) versions of the OS and Play Services using the Samsung Smart Switch software, connecting from my laptop to the phone via USB. See method 4 at this link: geeksquad.co.uk/articles/… – EleventhDoctor Nov 21 '16 at 13:59

Here is the way to fix this issue: go to APKMirror, find the last Google Play service, then download and install it. That's it. If you are having any problem then just go to the Settings → Applications → All → Google Play Store → then Uninstall Updates.

I've experienced this problem also and I found out the cause of it. So when you access any Google stuff the Google Play Services are used right.

Okay, that means that each time you play around any app using those services, it s going to require your device to be awake and/or keep the device awake. For some time I have used the Privacy Guard to make a restriction for this behavior i.e. to stop the apps from keeping my phone awake, even though it's locked/asleep.

So I went to the Privacy Guard and set the setting to "Ask every time" and what do you know, it started popping like crazy.

In conclusion: when you need to use the Google Play Services - set the permission for it to "Allowed", if you don't need it - that's when you want to stop it from draining your battery like crazy, then set it to "Denied".

Error: Unfortunately Google Play services has stopped working. The problem is in the updates. I fixed this problem by uninstalling updates from the Google play services app. All my Google apps started working. I went back in and reinstalled the update and it stopped working again so that tells me it's in the update. Go to Settings - apps - google play services. Do a force stop on app, clear cache and data. Check and see if your google apps are working. If you reinstall the update it may stop working again.

  • This worked for me! I have no idea why this has been downvoted! – Fedor Steeman Oct 23 '17 at 5:42

I've been having wakelock issues for the past week (OnePlus One) and today narrowed it down to googleplayservices. After some searching and reading, I went into Privacy Guard and turned permissions off for "Wake up" and "Keep Awake". My handset was again able to go to sleep after the set 15 seconds, but then that "Unfortunately, Google Play Services has stopped" error started popping up every 3 seconds in an endless loop.

I didn't connect the dots until this thread (hours later). Turned each back on separately to confirm. It's the "keep awake" that was the culpit. They're both on again, and I assume my phone will again have insomnia until whatever is wrong with the last update gets fixed.

I assume that googleplayservices needs to keep checking for something and preventing it from keeping the phone awake was causing the error loop. Maddening, but I can say from experience that that looping error is far worse than having to manually turn off the screen!

protected by Community Dec 12 '15 at 18:29

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.