7

Under the Settings -> Accounts -> Google, there's an account in the Accounts section and under that it says "sync turned off."
When I tap on it there is a list of services that can be synced (e.g. App Data, Calendar, Gmail, Google Play Books, etc.) and I can manually tap one of those to sync it now.
How do I enable automatic sync?
I don't see any option to "sync automatically" (only "sync now") from within the account nor from the Google Accounts page.
It used to sync automatically, and I'm not sure what happened or why it doesn't anymore.
How do I get that back?

4

Go back to the Settings menu, and in the Wireless and Networks section tap Data Usage. Then press the menu button and in the popup menu check the Auto Sync Data box.

You can then return to the Google account page mentioned in the question, where the list of services is, and select the newly visible checkmarks next to which ones you want to automatically sync.

1
  1. On your mobile device, open Settings.
  2. Under Personal, touch Accounts.
  3. In the top-right corner, touch Menu More.
  4. Check or uncheck Auto-Sync Data.
  • This is also correct - depends on your version of Android. – Tony Maro Nov 7 '16 at 2:36
  • Does this setting appear even on latest Android versions (6,7 etc.)? – soshial Jan 4 '17 at 16:57
1

Go back to the Settings menu, and in the Wireless and Networks section tap Data Usage. Then press the menu button and in the popup menu check the Auto Sync Data box.

You can then return to the Google account page mentioned in the question, where the list of services is, and select the newly visible checkmarks next to which ones you want to automatically sync. Remember to disable "Background data restriction" under Data settings sub-menu. Also don't forget to switch to more stable network connection like 3G, 4G poor network also causes syncing failure. Finally check if the core system apps that helps in synchronisation do really startup during booting (incase you anable auto start killer by some task killer apps).

1

Even more hidden is this... For Moto G 2015...

Go to:

  1. Settings
  2. Data usage
  3. Scroll down to Gmail
  4. Select Gmail
  5. App settings

Select one of your gmail accounts and there you'll find a check box to turn sync on, you'll probably also find you can change notification settings msg tones etc everything you lost ages ago and almost gave up on finding the answers to ;) ! Totally ridiculous

0

For me it's:

  1. Settings
  2. Personal > Accounts
  3. Press Menu key
  4. You will see checkbox (when it's selected it means it will auto-sync your data)
  5. Check it
  6. You will see popup with more info about auto-sync and confirm button
  7. Press OK

protected by Community Dec 8 '17 at 19:48

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.