I would like to disable the PIN/Password of my Android screen lock but I am unable to do that as the relevant option is greyed out. Please see screenshot:

(Click image to enlarge)


6 Answers 6


Please read the subtitle of every remaining button...

"Because you've turned on an accessibility service, your device won't use your screen lock to enhance data encryption."

You need to turn off accessibility services before you can change any settings here.

Settings-> System section-> Accessibility-> Turn off each process using the accessability services until you are allowed to change your password again.

A second cause may be what Journeyman said, but you seem to be running an older android version that doesn't support that.

  • Yeah, man... That's exactly what it was. Accessibility.
    – prl77
    Sep 18, 2015 at 4:45

It looks like your options for a non-secure lock screen are grayed out due to a security restriction. If you have, say, a work email account on your phone it probably requires to password protect the whole phone for security reasons. If this is the case, a possible solution would be to use a different mobile email client like Touchdown which only locks the app itself instead of the phone.

  • This is making an assumption, yet you have posted it as an answer. Can you validate this statement? See the answer from Ethan - do E-mail accounts have the availability to act under the accessibility service and prevent the "no password" option being selected?
    – DankyNanky
    Sep 17, 2015 at 10:33
  • 1
    @MichaelNancarrow - To answer your question: YES, email accounts do have the ability to disable non-secure lock screen options. For instance, if you use the Outlook or similar app or sync your Exchange account through the stock email app you will probably be required to have a secure lock screen. This has nothing to do with the accessibility service. As shown in the screen capture above, the two lock screen options the OP wants to use are "Disabled by administrator, encryption policy, or credential storage". We should wait for the OP to clarify before you criticize.
    – paulmz
    Sep 17, 2015 at 15:10

I have had that happen because I had a second/guest account setup (and that was a pain cause I use a third party lockscreen and I had two lockscreens to contend with). Remove the guest account, and that option should reappear.


This can happen because an app has added a user certificate to the credentials and requires a screen lock as part of it's security policy. MITM proxy apps or VPNs that support https do this. Once the app is removed often the user certificate is left along with the restriction making the option to remove the screen lock appear disabled.

To fix this go to settings->security->credential storage then select 'clear credentials'. this will remove user certificates and security restrictions which will allow you to remove the screen lock. If you select 'trusted credentials' to display the list, the CA certs from the installed android package should be reloaded.

This worked for me on Android 4.1.2.


Go to settings - fingerprint and password - smart lock - on body detection - turn it off


Go to Settings → General → Security → clear credentials. Now, you should be able to select any of the screen lock options.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .