1

Wondering if anyone is able to help me. I've been trying to root my OPO, but unfortunately RootChecker keeps coming back that the root access hasn't been installed properly, and SuperSU says "There is no SU binary installed and SuperSU cannot install it. There is a problem ... You need to manually re-root...". I've been using a few guides, but have primarily been trying to root using terminal https://forums.oneplus.net/threads/like-a-boss-how-to-root-your-oneplus-one.58493/ and have also tried the One Toolkit made by Consistant at XDA.

Steps taken so far:
Unlocked bootloader (checked it is unlocked, code shown below)

(bootloader)    Device tampered: true
(bootloader)    Device unlocked: true
(bootloader)    Charger screen enabled: false
(bootloader)    Display panel: 
OKAY [  0.006s]
finished. total time: 0.006s

Flashed TWRP custom recovery.
Flashed SuperSU.zip
I have also tried flashing SuperSU whilst booting TWRP through my mac (as in the guide).

Phone details:
CM 12.1-YOG4PAS1N0
Android v5.1.1

Any ideas? Thanks for your help.

  • This is rather odd. Few days ago when I installed 12.1 all I did to root was (my bootloader was already unlocked) boot into TWRP recovery (version was 2.8.6.0) -> flash the Beta SuperSU zip -> once successfully installed I booted into Android -> it showed Android is upgrading and that's it. Launched my SuperSU and it worked fine. – Firelord Sep 18 '15 at 0:14
  • Yeah, the odd thing is that when I've booted back into Android, it spent a couple of minutes optimising the apps as you'd expect, but then it stated that the binary wasn't installed. – Cal Sep 18 '15 at 11:25

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.