3

I checked different tutorials to factory-reset my phone, and this one applies to my phone's model. I had once factory reset this phone successfully, but I have forgotten what had worked for me..

  1. I powered my phone off.

  2. I pressed Volume-Up + Volume-Down + Power buttons together, and the screen showed me two options: Recovery Mode and Factory Mode.

enter image description here

  1. First I tried to enter the Factory Mode by pressing the Volume-Down button, that showed me these options:

enter image description here

At this point the Volume-Up and Volume-Down were navigating between the options and the power button was doing nothing. Their combinations also did not work.

  1. So I pulled the phone's battery out, and did the entire thing again, but this time, I entered the Recovery Mode. But to my surprise I was given the following:

enter image description here

Select Boot Mode:
[VOLUME_UP to select. VOLUME_DOWN is OK.]

[Recovery    Mode]
[Fastboot    Mode]    <<==
[Normal      Mode]

BUT at this point none among the volume buttons or the power button are doing anything. What should I do?

  • 2
    What is your device? Is it a Mediatek, by any chance? – Tamoghna Chowdhury Sep 18 '15 at 15:25
  • @TamoghnaChowdhury Nope. It is QMobile Noir A50. – Solace Sep 19 '15 at 2:11
1

If you want to factory reset your phone, just go to Settings->Backup and Reset->Factory Reset. You will be asked to confirm. Now, your phone will reboot and wipe data (do a factory reset).

I will assume that your volume buttons work correctly otherwise. If this is a repeated issue, it might be a faulty bootloader in this regard. If you have to reboot to recovery, you can use adb reboot recovery from the terminal with your phone connected in USB debugging mode to your computer. It should succeed, unless you have a corrupted recovery. In that case, you should take your device to a service center.

0

Hope it's not too late... You should try another button instead of power button. The power button doesn't work on my phone either, but in my phone, it makes me press "Home" to make a choice.

Not the answer you're looking for? Browse other questions tagged or ask your own question.