1

Whole story

(Feel free to skip to the "The Problem" section. This section is included for completeness, and just in case if it actually is related.)


SMARTPHONE: SONY Xperia E C1504
Specs:
-RAM: 512 MB
-DATA/SYSTEM space: < 1GB (~700MB)
-DATA/SYSTEM used out-of-the-box: ~ 300-400 MB
-INTERNAL STORAGE: ~ 2 GB
-PROCESSOR: Qualcomm Snapdragon S1
-STOCK ROM: SONY: Android 4.1.1 - based ROM


SD Card: SONY 32 GB microSDHC Class 10 (U1)


The stock SONY ROM that comes with the phone is too bloated, filled with unnecessary features, apps, and other stuff that make the phone (close to) unusable. Not only that, but even more space is wasted with some "SONY PC Companion" installer that I don't really need (download it from internet, maybe? and NOT WASTE VALUABLE SPACE!!!)

It's so crazy, that I can't even update all the apps in the phone (even without installing other apps in Google Play) without getting "Can't update : Insufficient space available.". Not only that, but 512 MB of RAM struggles to keep up with Facebook/Twitter! (Yes, they come pre-installed.). Way to go, SONY.

(barely) Survived for 2 years, after rooting using KingoRoot, removing loads of system apps, getting an SD Card, and installing Link2SD. After that, some apps just stopped. Knowing an update was pending, decided to Unroot -> Use PC Companion to do clean install. Still SLOW, and storage problem persisted, so decided to Unlock Boot Loader -> Install TWRP -> Install CM10, CM11, or CM12, whatever was available. Latest that worked was CM11, but without camera (bummer), so CM10 was used. So much for Lollipop. :(

Running CM10 smoothly, updated everything, and installed a couple of apps, and now only 150 MB available. :(.


The problem

Installed Link2SD, created mount scripts, and rebooted. Now some apps that were previously on SD card, including Play Store, Play Services, Nova Launcher, etc. appeared magically. Since some were installed in CM10 after wiping, the were replaced by their respective SD card versions.When opening any of those apps, I am greeted by "Unfortunately, has stopped.". Recreate mount scripts / relink apps / etc, and prompted for a reboot.

Except the reboot eliminated all trace of those apps. Means Google Play Services is GONE!

Next logical step: delete those files and start over. Used an adapter, and it mounted it read-only!!! Tried other adapter: (seems) perfect. After deleting, unmounted SD Card. Surprise! Everything is back again!

Tried GParted (deleting all partitions and creating new ones, as well as destroying old partition table), and to no avail. Everything is back!

Even tried shred -f -v -z -x /dev/mmcblk0, and no errors reported.

So I'm left with yet another SONY product that doesn't work as it should. And it's a shame as I used to trust SONY products, as I thought they were of good quality.


Non-working or impossible:

-Buy a new phone.
-Deal with it, and just use the phone for calls and SMS. No WhatsApp, Telegram / Plus Messenger, etc.

Help? Please?

  • Did you use GParted to format the SD card after which nothing was deleted from it? – Tamoghna Chowdhury Sep 20 '15 at 5:03
  • If you've got a Linux machine near you, try running the badblocks command against the card – probably the card only consists of bad blocks (i.e. is broken). I had a very similar issue here: Everything I changed (files written/added or deleted) was "undone" within hours (when the "file cache" expired), no changes to the card possible. Turned out card was all bad blocks, replacement card worked fine. – Izzy Sep 20 '15 at 8:22
  • @TamoghnaChowdhury yes, I used GParted to do it. (All my machines run Linux as their daily driver, and Windows in-case-of-emergency) – Jonathan Precise Sep 20 '15 at 13:05
  • @Izzy Running right now! – Jonathan Precise Sep 20 '15 at 13:06
  • 1
    @Izzy Running badblocks -wvs /dev/mmcblk0 as root (I wanted to delete the whole card anyways, so used the destructive write mode) started spitting errors after writing 0xaa. Summary: Testing with pattern 0x55: ^C5.39% done, 36:06 elapsed. (0/0/31472640 errors) Interrupted at block 14328000. I ^C -ed it as I knew the whole card was filled with bad blocks. Ordering replacement... – Jonathan Precise Sep 20 '15 at 13:54
0

The description is a strong indicator of a currupted/broken card. I had a similar case lately (deleted files reappeared, added files disappeared, changes were undone), and used the Linux command-line tool badblocks to check the card (attached using a card reader). Even with non-destructive mode, it immediately started spitting errors – so I knew the card was "borked". Ordered a replacement, and everything worked fine again.

As you figured out in your comment already, you must tell badblocks the device to check. If the card has to be erased anyway, destructive mode is giving a more complete result (involving used sectors/blocks as well as unused ones):

badblocks -wvs /dev/mmcblk0

(which you used – so I assume you ran the badblocks binary on-device via adb shell or a terminal) or

badblocks -wvs /dev/sdb

(using a card reader on a Linux PC – make sure first the card really is at /dev/sdb, or you might destry some other storage device!) will tell you the state the card is in. If it starts spitting out many numbers (the IDs of the bad blocks), you know it's time to order a replacement.

  • 1
    Yes, I ran it from my Linux laptop. It already has a built-in card reader, so it was recognized as /dev/mmcblk0 (ArchLinux, don't know if Ubuntu is different.). Replacement ordered. – Jonathan Precise Sep 20 '15 at 14:09
0

You can always try:

1)Format/repartition SD card using a PC and ensure that everything in it has been deleted.

2)Wipe your phone from TWRP (data,cache,dalvik cache,system).

3)Reinstall CM10 from scratch.

4)Insert SD card.

5)Link2SD again.

6)Does it work now?

7)If it still doesn't work, it might be a bug in the ROM. See if the developer can help.

8) Of course, the culprit is probably a bad SD card. Try replacing it.

  • Thanks for the answer. Unfortunately, it didn't work. I think it has to do with the SD Card – Jonathan Precise Sep 20 '15 at 13:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.