2

On Samsung Galaxy Note 10.1 SMP600 when I try to to add a VPN I'm prompted for credential storage password. I have tried all the other solutions on SO and none of them worked. I have PIN code on the lock screen as well and I cannot clear the password as the option to do so is greyed out.

I talked to Samsung and they eventually told me I had to factory reset of the tablet! I want to know how to fix this once and for all. My device is rooted running stock ROM Kitkat 4.4.2.

1

This is a non-conventional solution (which might/might-not work for everyone) but can be helpful to others having the same issue.

Answer gathered from androidforum and google product forum

What we are trying to achieve is to Set-up a pin and fail to enter it deliberately to access recovery using gmail address and entering the VPN settings directly after google sign-in.


Steps to achieve this:

  1. Add a pattern lock and other information that goes with setting up a pattern-lock recovery.
  2. Reboot phone and when the screen presents itself asking for lock pattern enter 5 failed attempts.
  3. When theprompts says to wait 30 seconds, press OK and find the recovery button where you enter google account info.
  4. After signing-in go straight to VPN settings and enter a new pattern-lock/pin.

If the above mentioned steps does not solve your issue go ahead with the alternative method.

Alternatively you can make use of 3rd party app called QuickShortcutMaker and follow the steps as mentioned here

  • Sharath, I'm afraid this doesn't answer the question: OP didn't ask for a list of VPN apps (which would have been off-topic) – but about solving the issue with credential storage. Could you edit your post and fix that (before downvotes come hailing down on you)? – Izzy Sep 20 '15 at 8:27
  • @Izzy thank you for letting me know. Edited now. My bad, I thought it was a software rec post. – Sharath Kumar Sep 20 '15 at 16:08
  • Yupp. Hint: SR=blue-favicon, ASE=green-favicon :) Or in my case, I take a look at the rep in the SE „MultiCollider™“ bar #D – Izzy Sep 20 '15 at 16:14
  • 1
    @Izzy Thanks for the tip, I'll keep that i mind. Also good tool, Multicolloder and also IzzyonDroid ;) – Sharath Kumar Sep 20 '15 at 16:16
  • I have tried both of these methods before and even retried them now, however neither of them work for me. Whenever I get the open VPN stage I'm prompted for credential storage. – preezzzy Sep 20 '15 at 17:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.