I have updated from Windows 7 to Windows 10 and now can't get my Galaxy S4 to connect via USB to my computer to download photos etc.

I have Kies ordinary and lite, both up-to-date, but still nothing. The computer says to put the phone into MTP mode, but that is nowhere to be found. Please advise.

  • Make sure you have a USB cable that supports data and not just for power!!!
    – user144465
    Jan 3, 2016 at 17:23
  • Use shareit to transfer file between your pc and phone Nov 20, 2016 at 9:44

5 Answers 5

  1. Connect your galaxy S4 to the PC first (don't bother if not recognized). Go the the Device Manager (Right click on ‘My Computer’ and select ‘properties’ then ‘Device Manager’ in the left sidebar, or go to ‘Control Panel’ then ‘system’ then ‘Device Manager’ from the left sidebar).

    Next, find the Android device driver if found then right click uninstall. The driver may be listed under ‘Portable Devices’ or ‘Other devices’ or it may be listed under it’s own name.

    Once the drivers are uninstalled, unplug your device from the PC. Make sure your computer is connected to the Internet and automatic updating is turned on, then replug your device and allow Windows to find and install the drivers all over again.

  2. If your device is not listed in the drivers list then check whether you are using the Right cable ( cable with data transmission capability not just charging).

  3. Provide the unlock password on your device in order to view external or internal memory on your PC.

  4. In windows 10, go to setings->Devices->AutoPlay. Tap to choose what happens to the devices after connected.

enter image description here

Alternative or best solution

Move to AirDroid for transferring contents from your system wirelessly to your phone or vice versa.


This still seems to be a problem for many people.

1) Download the Samsung mobile USB driver.

2) Unplug phone & install driver.

3) After install, plug in phone. It should be recognized but open Device Manager and scan for hardware changes. Windows may possibly then do a driver update.

AND/OR: TRY ANOTHER USB CABLE! This has worked for many people including myself. I'm a fan of Monoprice cables. I throw away any cables that "seem to work" under some circumstances (like charging) but not others (like MTP connections in this case.)

  • I'll second bmdixon's "try another usb cable". I tried three that didn't work (#1), but that had seemed fine for other devices. I finally found my original Samsung USB cable and tried it ... and my Mac saw my Galaxy S7 Edge! #1: when plugged in with the other cables, the phone chirped and started charging, but there was no recognition of the phone by a Mac or a PC. Jul 14, 2016 at 18:00

I was experiencing the same issue and it was rather flustrating. However, thanks to a source online, i was able to get this fixed.

First, you need to make sure you have usb debugging turned ON on your android phone. Although not compulsory with some android smartphones, it's kinda compulsory on some others. But it wouldn't hurt to have USB debugging turned on anyway.

Next, you need to update MTP driver on your computer. Plug in your device to your computer using a working usb and follow the steps disclosed in the screenshots below:

Right click on the windows start icon and click on Device manager, then go to other devices and right click on the unknown device or MTP (whichever your computer currently displays):

windows 10 not detecting android

OK. It seems as though stackexchange only permits only one image. Or maybe i don't know how to add more.

But here is the link to the source. Perhaps, you could check and fix your issue.


AirDroid is probably your best bet. Depending on your wireless carrier, the drivers may be unsigned and not current enough for Windows 10. For Verizon, my Galaxy S4 drivers aren't signed so I can't install. AirDroid provides me the ability to transfer content. Some wireless FTP apps, even installed from the play store, can result in mixed results.

  • USB debugging turned on - seemed to doo it for me. tks
    – HattrickNZ
    Sep 10, 2017 at 1:28
  • in addition: it was a very intermittent connection. but could access the sd card on the phone for moving pics from there to the laptop.
    – HattrickNZ
    Sep 10, 2017 at 1:39

We had tried pretty much all of the recommendations found on various sites. Nothing worked. The lower-level error was "Port Reset Failed". I discovered that using a POWERED USB hub between the phone and the computer eliminated the problem. Later we learned that one of the three cables we had would work without using the hub. My speculation is that the amount of power the phone is allowed to draw from the computer is somehow controlled by the Samsung cables. Those that ask for a higher draw will only work thru the powered USB hub (because the computer doesn't power the device then).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .