10

How do I cancel the sending of a queued email in Gmail (Android)? The conversation is in the outbox and I don't see an option for deleting the message alone. I'd like not to have to delete the whole conversation.

I am temporarily in China where Google is blocked and I want to rewrite an email I had written and tried to send.

migrated from webapps.stackexchange.com Sep 21 '15 at 14:14

This question came from our site for power users of web applications.

11

I didn't try Matthew's solution but it seems the safer solution to try first.

If that doesn't work though, I deleted the entire conversation from the outbox, having given up on trying to keep the conversation. I was surprised to find that this only deleted the queued message. The rest of the conversation stayed intact in my inbox.

  • 1
    This worked for me, thanks! I agree Matthew's solution seems safer, but in my case I had another way of (sort of) recovering the conversation so I gave your solution a shot because it was quicker :-) – Kannan Goundan Mar 1 '16 at 6:54
4

One way would be to clear the data for Gmail via the Settings app.

  • 2
    This worked, however, when you go back to Gmail you'll get any prompt screen that you previously dismissed, you'll have to re-enter any personal settings and Gmail will then have to re-sync all of your email. For me, that took a long time. That being said, it worked! – Mark Cramer Nov 17 '16 at 21:22
1

I'm at Boston/Logan airport and have the same issue. Went to Gmail settings, turn off Auto Snyc,roll the days counter to 1 or 2,and do a manual sync. Worked for me, this issue only since marshmallow update 2 weeks ago.

0

I figured out how to delete a stuck queued email. Open tbe main menu list from the button at the top left and go to Outbox. The stuck queued email will be there and easy to delete.

  • 1
    Well, the whole point was the fear that deleting from outbox might delete the entire conversation (multiple emails), because that's what it looks like in the outbox. But it turns out that deleting the entire conversation there still preserves the conversation in the inbox. Thanks for your input though. – Andrew Cheong Jul 13 '17 at 15:19
0

For me none of the posted solutions worked. But what did work after trying everything else, was phone settings, disable battery saving mode. There must be some configuration there that causes messages to queue.

-1

Try to press and hold and the option will appear. I did mine through this.

Not the answer you're looking for? Browse other questions tagged or ask your own question.