1

How can I get my M8 to boot up again? It freezes at the white screen where it says htc.

Some background:

  • To run the software update on my rooted M8 I had to put stock recovery back on it. I did that following the instructions of this video.
    1. After successfully putting stock recovery back on I booted and proceeded to download the update and install it.
    2. The restart after the update was the first time it froze up on me. I saw the green bar proceeding and after that it tried to boot. Oddly enough it froze on the "second bootscreen" where it still stays htc, but smaller and there's that big black ONE (note, that the phone was still connected with my computer, if that plays any role).
  • I first had to find a way to shut down my phone, since you can't just remove the battery. I've found out, you can do so by pressing and holding Power and Volume Up.

What I've tried:

Today, I've found this article, which pretty much includes everything I tried, just explained for dummies. This includes:

  • Putting Custom Recovery (TWRP) back on
  • Clear data cache in TWRP
  • Wipe / factory reset in TWRP
  • Putting stock recovery back on
  • Fastboot from bootloader
  • Clear cache in stock recovery
  • Factory reset in stock recovery
  • Shut off in stock recovery and power on afterwards

Nothing of the above has fixed my issue. It still freezes while booting.

I obviously have lost hope in keeping my apps and data (most data is safe on SD card). All I'm trying to do is to get a working phone again.

I'm not very familiar with TWRP nor unlocking itself (just did it to have certain apps, like TitaniumBackup) so is there something in TWRP I can try?

My phone is not a branded (AT&T, Sprint, whatever) one. Please also note, that it's not a bootloop. My phone doesn't shut itself off.

This is what the bootscreen looks like, at the moment:

*** Software status: Modified ***
*** UNLOCKED ***
M8_UL PVT SHIP S-ON
HBOOT-3.19.0.0000

I can complete this list, if you want me to

The only difference to the bootscreen in the video I linked above, is that mine has the addiditonal line *** Software status: Modified *** and is S-ON

Please also note that I got the stock recovery on it right now, so start your instruction form there.

Thanks a lot! I'm running out of ideas.

  • 1
    All is not lost but your best bet to get your phone back is to flash it totally back to stock with official firmware. They upped the security with lollipop so your device cannot not be modified at all to take OTA's. OTA's are also risky but it's a simplistic way to reach millions of of people. – Bo Lawson Sep 23 '15 at 17:03
  • @BoLawson Thanks! I though about that. How can I get the official stock ROM? Can you give me any link? I'm trying with this program, htc provides(all the way at the bottom). But it's 1.4GB to download and I guess it would be faster to flash the ROM with adb commands? – Alex Sep 23 '15 at 19:00
  • 1
    With HTC official firmware the MID and the CID all have to match up to the firmware you are flashing. As far as a ROM it all depends at what stage things died at and what your preferences. I do not have enough info to find either check xda but be careful make sure everything matches up. – Bo Lawson Sep 23 '15 at 19:43
2

I had the exact problem after going back to stock then applying the OTA. I had to reinstall TWRP (I used "fastboot flash recovery twrp.img" according to the instructions here).

Then I just flashed another ROM from the SD card, which have gotten beeter since I last checked. I recommend Viper or Adrenaline 2.4 androidrevolutions.com/neo/ADRENALINE/m8/

  • 1
    Thank You very much! To answer my question for everyone else who is looking for stock ROM: Install any custom recovery, like Jamie explained with TWRP, and then download the stock nandroid backup from this XDA-devs article. Then simply copy it to your device and restore that backup via the custom recovery. – Alex Sep 24 '15 at 16:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.