0

My Moto X upgraded to Android 5.1 recently and since that happened I cannot connect to WiFi.

When I try to connect to a saved network, it will briefly show "Connecting..." underneath the WiFi SSID, then it will revert back to "Saved".

I have tried the following and gotten the same result:

  • Turned off WiFi, then turned it back on.
  • Rebooted my phone.
  • Rebooted my router.
  • "Forgot" my home WiFi network then re-connected and entered the password
  • Changed WiFi frequency band on my phone
  • Tried connecting to a public WiFi network at a coffee shop.
  • Reading this thread: phone won't connect to wifi after upgrade to Android 5.1

Occasionally I will be "connected" to the WiFi, but I won't be able to get any data. When this happens, the WiFi symbol usually shows an exclamation mark over it. Most of the time though, I can't connect whatsoever.

0

I'm going to recommend you to try 2 things, then if all else fails contact Motorola.

  1. Clear the system cache. Many post-update issues can be fixed with this. It clears out all of your phone's temporary files, and after a update, the cache is usually junked up with all kinds of stuff. This site does an excellent job explaining the process. For users with other devices, a quick Google of clear system cache device name OS will get you what you need.
  2. Factory reset your device. It may seem bit extreme, but it usually gets the job done. Avoid restoring from a backup if possible as it may restore the issue as well.

If that doesn't work, Motorola has a decent customer support system, but expect to be on hold a lot. (At least less than Comcast)

  • I cleared the cache, and I'm still having the same WiFi issue. Will a factory reset take me back to a previous Android version or will I remain on 5.1? – jewbix.cube Sep 24 '15 at 3:52
  • @axle123 You will remain on the operating system you are currently using, so yes, you'll stay on 5.1 sorry I didn't respond so quickly. Middle of the night for me. – Ethan Z Sep 24 '15 at 10:28
  • Just a quick note (if you haven't already noticed) the Android mobile radio active bug is very prevalent on this device. code.google.com/p/android/issues/detail?id=165558 – Ethan Z Sep 24 '15 at 10:35
  • I ended up doing a factory reset and was finally able to connect to my home WiFi. – jewbix.cube Sep 29 '15 at 17:54
  • @axle123, sometimes that is what is necessary – Ethan Z Sep 29 '15 at 18:23

protected by Community Apr 1 '16 at 17:57

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.