0

I've got a Samsung S6 G920F with Android 5.1.1 which I've tried to root by using the Chainfire method through Odin. Sadly something went seriously wrong when I ran the rooting and my phone is now stuck displaying the Recovery is not Seandroid Enforcing message when I try to turn it on. I've tried just redoing the rooting but it doesn't help.

So what I basically want to do is to undo the whole thing, or get this rooting to work asap.

And also, this doesn't seem right: Current Binary: Custom, System Status: Official

The log from Odin:

<OSM> Check MD5.. Do not unplug the cable..
<OSM> Please wait..
<OSM> CF-Auto-Root-zeroflte-zerofltexx-smg920f.tar.md5 is valid.
<OSM> Checking MD5 finished Sucessfully..
<OSM> Leave CS..
<ID:0/004> Odin engine v(ID:3.1005)..
<ID:0/004> File analysis..
<ID:0/004> SetupConnection..
<ID:0/004> Initialzation..
<ID:0/004> Get PIT for mapping..
<ID:0/004> Firmware update start..
<ID:0/004> SingleDownload.
<ID:0/004> recovery.img
<ID:0/004> NAND Write Start!! 
<ID:0/004> cache.img
<ID:0/004> RQT_CLOSE !!
<ID:0/004> RES OK !!
<ID:0/004> Remain Port ....  0 
<OSM> All threads completed. (succeed 1 / failed 0)
<ID:0/004> Removed!!

Log after trying to install firmware:

<ID:0/004> Added!!
<OSM> Enter CS for MD5..
<OSM> Check MD5.. Do not unplug the cable..
<OSM> Please wait..
<OSM> G920FXXU2COH2_G920FVDS2COH3_G920FXXU2COH2_HOME.tar.md5 is valid.
<OSM> Checking MD5 finished Sucessfully..
<OSM> Leave CS..
<ID:0/004> Odin v.3 engine (ID:4)..
<ID:0/004> File analysis..
<ID:0/004> SetupConnection..
<ID:0/004> Initialzation..
<ID:0/004> Get PIT for mapping..
<ID:0/004> Firmware update start..
<ID:0/004> boot.img
<ID:0/004> NAND Write Start!! 
<ID:0/004> Complete(Write) operation failed.
<OSM> All threads completed. (succeed 0 / failed 1)
0

I did this with my own bad script experimenting I injected in the s6. The way to fix it is to get and flash official firmware. You should still be able to enter download mode.

  1. Get official 5.1.1 firmware I got it from sammobile and verify md5.
  2. Open up Odin 3.10 with administrative privileges and plug your device in and load the firmware into odin
  3. Press start and flash once done it should boot like before
  • Something with the write operation goes awry. Check the log in my updated op. – bork Sep 25 '15 at 7:27
  • @Bork Use odin 3.10 run with administrative privileges and make sure you have the correct firmware for the region you are in and re-download it. Odin aborted super quick in the beginning... – Bo Lawson Sep 25 '15 at 14:26
  • thank you! using the "Run as administrator" option did the trick. Update your post and I'll accept it as a solution. – bork Sep 25 '15 at 16:10
  • @Bork good stuff your up and running again. What happened with me is the 5.1.1 update patched something in security. So make sure if you inject script into your devices system it is for the current version. I learned that the hard way. – Bo Lawson Sep 25 '15 at 16:33
0

Check if you can reboot to stock recovery (Switch off the device completely. Boot into recovery mode by pressing and holding Volume Up, Home and Power keys at the same time. Release all three buttons when device screen flickers and the main screen of Recovery mode appears), from there you can factory reset your device.

  • I tried and nothing happens at all. – bork Sep 24 '15 at 14:31
0

From what I can see in the firmware install log, you are flashing only the boot image (boot.img). Download the full firmware from sammobile or samsung-updates.com and try flashing again.

  • Also try redownloading or using another version of Odin. – nicestguy Sep 25 '15 at 12:15
  • 1
    Done and done. I've tried the latest version of 5.1 from sammobile and I've used Odin3 v1.85 and Odin3v3.07. However, when I use the older Odin version I get a fail message but when I use the newer version it just get stuck att SetupConnection. – bork Sep 25 '15 at 12:32
  • Try Odin v3.10.7 and try downloading from samsung-updates.com. I personally download all my Samsung firmware files from there. – nicestguy Sep 25 '15 at 12:39
  • The process still sticks at SetupConnection. – bork Sep 25 '15 at 12:48
  • Check this forum : forum.xda-developers.com/galaxy-s3/help/… There are a lot of answers for Odin getting stuck at SetupConnection. – nicestguy Sep 25 '15 at 12:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.