0

I recently purchased a Galaxy S5 on http://amazon.co.uk. This was a well deserved upgrade from a galaxy S2.

When I got the phone I powered it on with my Vodafone Spain SIM card and it worked perfectly. The day after I realized that there was a system update and I ran it. As soon as the update ended the phone asked for "SIM Network Unlock PIN"

Is there any way to revert this update? is reverting the best option?

Can I unlock the phone without buying an unlock code?

I found this site http://unlockcode4u.com recommended by a friend and they seem capable of unlocking the phone, but I just expended £250 for the phone and the code is really out of my budget.

Please help.

  • First contact your service provider Vodafone Spain because OS upgrade does not cause such issues. – Ankur Jain Sep 24 '15 at 12:55
  • Thanks for your reply. I purchased the phone as new and unlocked in amazon.co.uk. Does my provider have something to do with this update? – P. Camp Sep 24 '15 at 19:38
0

My suggestion would be to talk to your network provider and ask them why are you seeing the above mentioned error message only after updating the firmware. Ideally it should not happen as you have bought an unlocked phone.

  • Thanks for your answered. I did contact Vodafone here in Spain but they actually did not know how that happened. I was on the phone with them for over an hour and no solution was given. Eventually after all my frustration on the phone and researching online for a solution, I finally went back to this guys unlockcode4u.com and bought the unlocking code. My phone went back to work after 2 hour with their unlocking code. I should have done this from the very beginning and saved me all the hassle. – P. Camp Sep 30 '15 at 15:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.