1

A while back when the OTA update came out for Lollipop 5.0, the tablet became exceedingly slow, practically unusable. So, I followed the instructions in https://developers.google.com/android/nexus/images and reinstalled the 4.4.4 ROM. The system continued to offer the upgrade but I ignored it. Today, I tried to install it. It is offering 5.0.2. It says that it has already been downloaded (~300Mb) but when I tap on Restart and Install, it says "rebooting in x seconds" until it says "rebooting now" but never does. The it says "downloaded and verified" again and the button changes back to "Restart and install" from "cancel install"

I tried doing this operation in safe mode but to no avail.

A few weeks ago, I cleared the cache partition a couple of times, if this has any importance.

Is there a way to redownload Lollipop OTA without sideloading?

2

Your easiest option is to sideload the update.zip file.

Better option would be to download and flash the system image if you havent done it since 4.4

Sideload: Download the proper image file and adb drivers for your OS from google and install drivers. Now boot to fastboot by pressing Power + Volume down. Now check if you have connected by typing fastboot devices in terminal/prompt. If your device is listed, continue to flash by running the script file from the downloaded image zip.

This method may work on other non nexus devices but you require proper image files from manufacturer or third party and you may require to go through extra steps before you can use fastboot.

This requires you to have unlocked bootloader. Use fastboot oem unlock to unlock your bootloader.

  • 3
    Could you expand this answer to explain how to sideload/download & flash the system image? – Andrew T. Sep 25 '15 at 3:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.