Firstly, I am running CyanogenMod 12.1 on my HTC One M8, but this is an issue I also experienced running stock Android (e.g. Lollipop).

The issue I am experiencing is that my device appears to be unable to reconnect or "get back" on the Sprint data network. For example, yesterday, I was in NYC (obviously somewhere that should and is covered), but I was unable to get a data connection anywhere in the city. I was only able to send SMS (not send/receive MMS) and make voice calls.

In the past, when I had this issue on Sprint, being the helpful individuals they are, they told me to restore my phone and reinstall Android. I did that, which helped for a while, but it wasn't long before I ran into the same issue on stock Android. After a while, the issue seemed to "resolve" itself magically. I never found out why or how.

More recently, I rooted my phone and installed CyanogenMod 12.1 on my M8, and I am running into the exact same issue I had before. Ideally, I don't want to have to restore my phone again, because not only do I not think this is the "fix-all", but it seemed like Sprint's lazy answer for not wanting to actually troubleshoot my device.

This is becoming increasingly apparent when I travel as I am unable to get GPS directions, send MMS messages, or do anything over data like normal when I'm off of a WiFi network. Despite having "bars" on my screen, CM will display a small "!" over my data icon, which I assume is an indicator that it is unable to connect to the mobile network in some way.

Is there anything I can do to better troubleshoot my mobile data connection?

  • Verify your APN is correct for sprints network.
    – Bo Lawson
    Sep 25, 2015 at 2:32
  • @BoLawson I went to check my APNs for my device, and it displays an empty list with a message, "Access Point Name settings are not available for this user". Does this mean it needs to viewed as root or something? I found this guide online, but I'm reluctant to just blindly type something in online that could potentially risk sending confident information to someone. What are your thoughts? Thanks!
    – J.W.F.
    Sep 25, 2015 at 2:41
  • No you do not need root to view the APN. First I would call sprint and ask them for the proper APN or check their website. If the list is blank then that is most likely the issue.
    – Bo Lawson
    Sep 25, 2015 at 2:50
  • @BoLawson I'm experiencing really strange behavior on my phone… this morning, I checked my APNs and the list was full of them, for CDMA APNs and Sprint LTE APNs. However, I locked my phone and looked at it about ten minutes later, and it displayed the same message I mentioned above. I'm not sure what to do now, I don't know if the APNs are being saved or not? And I'm trying to find the official information for Sprint APNs but it seems like I'll have to phone support, they don't keep it anywhere obvious.
    – J.W.F.
    Sep 25, 2015 at 13:52
  • 1

2 Answers 2


The same thing happened to me after I rooted and installed CM.

I seem to have just solved it by going into the Access Point Names menu, opening the 3 dot drop down menu and selecting "Reset to Default" and rebooting the phone. I then went back into said menu, clicked the add (+) button and entered a new APN with the settings as follows:

Name        : Sprint
APN         : cinet.spcs
MMSC        : http://mms.sprintpcs.com/servlets/mms
MMS Proxy   : 6
MMS Port    : 80
MMC         : 234    
MNC         : 15    
APN Type    : Internet + MMS
APN Protocol: IPv4

I left every other field blank, saved it, selected it from the previous menu and restarted. Everything seems fine now, I've got full LTE where I had sporadic 3G (mosty no signal) in this same spot just moments before. Granted it's only been an hour so time will tell.

Source (and steps for some models): 4GTricks - Sprint APN Settings For Android, Samsung Galaxy, HTC One, Xperia, Motorola Moto, LG G1

  • I'll give this a check next time I lose my data signal. My issue is recurring between "having data" and "no data". Right now, my data signal magically started working last week, but we'll see how long this lasts…
    – J.W.F.
    Nov 19, 2015 at 5:14

Don't know if my solution will work for anyone else. I added an APN, but got no radio button to choose that APN. I then added the same APN again, and the second one sprouted a radio button to select it, and it started working. I have NO idea why. I also had the message that there were too many (0) APNs and I should delete some, and the message that the SIM was non-Verizon SIM. This just points out that trying odd things sometimes works.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .