3

It's seemingly impossible to browse American Express www.americanexpress.com in desktop mode on Android.

I've tried Chrome and Dolphin browser, also tried searching for a button on the site that would bring desktop mode.

2
  1. Install Firefox browser by Mozilla.
  2. Visit American Express
  3. Click the three vertical dots near address bar and select "Request Desktop site".

    IMG: American Express Desktop mode in Firefox 40

    Screenshot - (Click to enlarge image)

You may also try to use their Android app "Amex Mobile" available on Play Store.

1
  • Visit americanexpress.com in your default browser.
  • Scroll down to the end of the page and Select "Full Site"
  • Disable JavaScript in Site settings

    Screenshot
    Click on image to enlarge

  • I'm using Chrome Browser as my default browser and it works.

  • 1
    The [Mobile | Full Site] link is not visible to me in Chrome. Can you post the URL of the screenshot you posted? Yours is different than mine. Also what version of chrome are you using? – Lucky Sep 25 '15 at 8:19
  • 1
    I agree with Lucky. I don't see that option either. I even tried global.americanexpress.com but to no avail. – Firelord Sep 25 '15 at 9:06
  • 1
    You're right, my bad, the url in my browser got redirected to "americanexpress.co.in". Chrome's request desktop site does not work with "americanexpress.com" – Manubhargav Sep 25 '15 at 9:15
  • 2
    @Lucky url www.americanexpress.com ignores the request desktop site from chrome when javascript is enabled. So disabling the javascript did the trick. @Firelord Edited the post, now everything works like a charm. – Manubhargav Sep 25 '15 at 11:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.