3

Good Morning. Yesterday I was excited to flash CyanogenMod 12.1 in my other Android device. The process was the same and I did everything correctly. Unfortunately, after flashing Google Apps, the system wouldn't stop showing pop-ups like "google app has stopped", "google services has stopped". Nothing about Gapps works, even the keyboard. I have tried to wipe data/factory reset, using CWM and reflashing CM12.1 ONLY, but it didn't work. The pop-ups are still there. Maybe there's some Gapps fragments in the system... Please, I would appreciate any possible help. Thanks

bumped to the homepage by Community 19 hours ago

This question has answers that may be good or bad; the system has marked it active so that they can be reviewed.

  • Did you flash the correct version of GAPPS? From where did you download it? – Firelord Sep 25 '15 at 11:23
  • A few years ago you were meant to boot into Android (for the first time after flashing), leave it for a minutes so it's fully boot (don't interact), then reboot. If you didn't, you would get exactly the same symptoms as you have. – Tom Sep 25 '15 at 12:16
  • Since the CM version is not official, but ported, I searched all over the internet to find the correct Gapps version. I didn't find anything, so I flashed Gapps from CyanogenMod link. Isn't that supposed to work on every ROM? (The device is the old, old, old Samsung Galaxy Express) – Flvio Hergersheimer Pinguim Sep 25 '15 at 14:02
  • The gapps is changed for each version of android. Try tk gapps, search it on Google and flag it on your ROM. As I presume as the CM 12.1 isn't an official update, so you are downloading a previous build of gapps, which was for 5.0.2 version of lollipop, or in your case CM12. – Hunter Sep 26 '15 at 11:31
  • I found the correct one! But the problem persists! After all the popups, all google apps that I open says "this app is not installed" – Flvio Hergersheimer Pinguim Sep 27 '15 at 3:01
0

It is recommended to wipe dalvik/cache, factory reset before and after flashing anything in recovery.

So here are the steps to solve the problem

  1. Enter CWM recovery mode
  2. Wipe data/factory reset
  3. Wipe Cache partition
  4. Advanced > Wipe Dalvik Cache
  5. Flash Gapps for CM12.1
  6. Wipe data/factory reset, Cache partition
  7. Wipe Dalvik Cache
  8. Reboot
  • Great website for a collection of gapps, then does it have tk gapps, it could be resourceful. – Hunter Sep 26 '15 at 11:34
  • For future readers I can confirm that the above 8 steps worked for me. I had done all except the Wipe Dalvike Cache. I think that was the missing key that i was missing. I used it on a Int Note2, a nightly CM13, with OpenGApps for Android 6.0. Thanks Sharath – user184168 Aug 23 '16 at 13:34
0

A factory reset will not help,

You need to do a system wipe, then reflash CM 12.1 only and then flash gapps.

  • Wipe old system

  • Install new system from zip

  • Install gapps package

  • Wipe Dalvik & Cache

  • Reboot

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.