1

I have a Sprint HTC One (m7wls) and recently switched over to Ting. I was using Cyanogenmod and couldn't use Ting's instructions for activating with them, so I used an RUU from HTC to get back to stock. Now I can follow the reset instructions, but they don't seem to be working. When I enter # # 72786 # I can see some fields (MDN, MSID, M.IP Customer Profile...). Not sure how important it is, but the MDN and MSID show 'No' rather than any info. So then I tap 'Reset' in the menu, and the phone reboots but then that's it. No more activation activities happen on their own from there. I can continue to Update Profile and Update PRL in settings and that will get me a 4G connection, but still no cellular network (no texting or calling and no bars).

Using code # # 3282 # gets me into a more advanced menu where I can see more fields (other than MSID and MDN) and alot of them say 'No'. I have that Slot Mode is enabled, but there's a 'No' under Slot Index. Mobile Country Code and Access Overload Class also say 'No'. I'm not sure what they all are, but I thought I'd mention them incase they help point to a bigger problem.

I'm guessing that part of the problem is the missing my MDN and MSID numbers, so I've been focused on getting those configured. I've tried using these menus to set the values (just MDN and MSID at first, but I've also tried once with just the Slot Index) and every time I tap 'Commit Modifications' in the menu to save it I see a toast that says 'Commit Failed'. Using captured logs from logcat and a decompiled version of the EPST I think I've found that it won't save anything because the Telephony interface indicates that the radio is still on when it's about to save.

I'd greatly appreciate any thoughts are explanations of how things work. I'm going to try a rooted stock ROM that will let me get into the EPST app. If I still see the same problems then I'm going to write an app that will let me turn off the radio (hence, the rooted stock) before trying to set the MDN and MSID. But I'm still worried about all those 'No's and am wondering if those will have to be set too before network connection will start to work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.