0

Accidentaly brick recovery mode on my cell (Star B943 MTK6589 quad core with Android 4.1.2), so I reinstall my recovery.img from backup (Android system recovery 3e) using mobileuncle tools. Worked fine. Cell is ok BUT recovery menu is now in chinese! On recovery boot, for a second, cell displays FACTORY MODE on second line, then displays chinese. How can I change to english?

cell is Star B943 Mt6589 quad with Android 4.1.2 with recovery 3e. What append- I tried to replace my recovery with CTRv2.2 (CarlivTouchRecovery from XDA forum) for MT6589 chips. Cell worked fine except for recovery mode. When I boot in recovery cell stuck on droid recovery logo. Need to remove battery to properly boot. So, I copied my (3e) recovery.img cell to root and ran Mobileuncle tools app available in Google store to reload recovery. Worked fine except now my recovery is in chinese! My intuition is that the recovery menu is language sensitive depending on some flag somewhere. I used MTK Droid Tools v2.5.3d to generate backup of cell, which I took the recovery image for Mobileuncle. Cell language is french.

  • Thanks! I've integrated that with your original post (to make it easier to spot). Now could you please also add some details (e.g. a link) on where you downloaded the mobile uncle tools, plus whether recovery still claims to be 3e? – Izzy Sep 25 '15 at 21:28
  • Dont know about recovery version as its in chinese. Only thing I can say, is when I boot in recovery mode, for a second, message FACTORY MODE is displayed on second line or the recovery. – ytherien Sep 25 '15 at 21:46
  • OK, thanks – then we have to go with this. I'm not familiar with MTK devices (but I know several others here are), so I leave the stage now. Fingers crossed, good luck and a fast, stable solution! – Izzy Sep 25 '15 at 22:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.