2

As you can see the "Recent files" in the picture, it's really annoying - it remembers every image which I just opened, thus violating my privacy.

Note that "Recent files" even remembers and shows my hidden images (which Images or Gallery won't scan and show).

I can make the "Recent files" forget about my recent images by going to Settings -> Application manager -> All -> My Files -> Clear data (check the second image), but that's just exhausted.

Is there anyway to completely remove this annoying "Recent files"?

In the past, I used Samsung Galaxy V and it doesn't have this "Recent files", then why my Samsung Galaxy Core Prime has?

(Click image to enlarge)

IMG: Recent files IMG:

  • Ugh, no but you can use other file explorers like es explorer, it doesn't has recent file. – Hunter Sep 26 '15 at 10:45
  • How is it violating your privacy? It's only showing your files on your phone to you. The only way it could hurt your privacy is if you choose to let someone else look at that list on your phone. – Dan Hulme Apr 16 '18 at 16:23
  • @DanHulme Imagine you give your phone to your 8 year-old nephew to keep him busy, and you have some sensitive photos... – 123iamking Apr 17 '18 at 0:43
  • That's not a privacy violation, that's just you sharing some stuff you shouldn't. – Dan Hulme Apr 17 '18 at 8:57
0

The solution is Clearing data in App info of My Files, After a few years using this phone, I think this is the only solution.

Slow way: Settings -> Application manager -> All -> My Files -> Clear data.

Settings -> Application manager -> All -> My Files

IMG:

Quick way: you can quickly open App info of My Files by holding the My Files app then drag it into the App info

IMG:

0

I'm using an LG Q7 to delete the files I went into file manager pushed the three dotted settings button, and selected show hidden. and searched through internal storage, found most of the thumbnails and cache in the pictures. A little digging as well in Android and DCIM was looking for anything that had a period in the beginning.

-1

In fact it is possible to do so. You just need to remove the cache files from Gallery and My Files then it removes recently added folders from Gallery and recent files from My Files.

  • Actually, the solution is already in the question: Settings -> Application manager -> All -> My Files -> Clear data. Note: that you can do it quickly with Holding the "My Files" app, drag it into the "App info" (I don't remember the exactly word is App info or not), then the app info page appear, in this page you can: Turn off the app, clear the app cache, data,... Thus you can Clear the app data in this page. – 123iamking Jan 19 '17 at 4:39
  • Welcome to Android Enthusiasts! This post does not contain enough information to be considered an answer. How did it solve the issue? Where to find it? What are the steps to perform? – Izzy Jan 19 '17 at 15:34
-1

Just open your files and tap the 3 dots in right upper corner, and select settings, then turn Show recent files off.

  • 1
    Don't know about that, but I never saw that option on my phone. Can you post the image? – 123iamking Apr 16 '18 at 3:14
-1
  • Go to Files
  • select the 3 dots on the upper right
  • Pick Settings and you'll see the screen below
  • Turn off Show recent files

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.