2

I'm currently using an LG G3 with Lollipop 5.0.1.

The problem I'm having is that when I'm using an app (or just doing something general on my phone) and I receive a text or similar notification a pop-up shows up on my screen explaining what the notification is. For example, the first sentence of a text, or a snippet of a Facebook post. I know this is normal but the issue is that if I'm currently doing something important and I want to clear the pop-up, if I swipe right (or press the "X") to dismiss the notification it clears it entirely i.e. from the Notification drawer too.

See the example of a situation where this happens, in order to clear up any confusion with my issue:

I'm sending an important email to a coworker when my friend texts me. I don't want to read my friend's text right now but the pop-up still blocks a portion of the screen. In such a situation my options are:

  1. Wait about 5 seconds for the pop-up to disappear.
  2. Clear the pop-up so I can resume emailing my coworker (preferred because it allows me to resume typing the email immediately).

The problem with option 2 is that if I clear the pop-up notification all other indications that I received a text are also cleared (meaning the top bar notification & the little red "1" on the messaging app). So if I happened to send a really long email to my coworker, there's a chance I'll completely forget to respond to my friend once I'm done.

So, is there a way to clear a pop-up notification without clearing all other signs of the notification?

3

Unfortunately, in Android 5.0.1 any action done to the notification that isn't opening it will dismiss it. If you can, upgrade to 5.1. In this version, swiping up on the notification will hide it but keep it in the notification panel.

3

In case, you'd like to globally disable the popup-cum-push notifications, you can consider the following method. This will only disable the popup ones, but notifications will continue to show up in Notification drawer, as usual.

Setup in PC, connect the device with USB debugging enabled, launch a shell on PC and enter:

adb shell settings put global heads_up_notifications_enabled 0

Done! Method is tested on COS12 (Android 5.0.2) running WhatsApp.

  • But some apps can evade this solution such as SlideLocker. Don't know how but they do. – Firelord Sep 27 '15 at 6:53
  • 1
    But It can be set to disable Heads-up banners in SlideLock locker as that's what the OP wants to achieve. This solution works for me, +1 for being the best solution. – Manubhargav Sep 27 '15 at 7:52
  • @Manubhargav I'd prefer not to disable popup notifications totally. What exactly are you talking about when you said Firelord's answer achieves what I want? – Paul Warnick Sep 27 '15 at 10:43
  • 3
    @PaulWarnick The above solution disables the 5-seconds-popup but the notification is present in notification drawer when you slide down. Firelord 's method fails only if you use the 3rd party app called slidelocker app which you clearly don't use. It suits your need, have you tried it yet? – Manubhargav Sep 27 '15 at 12:45
  • @Manubhargav Ah thank you, that clears things up. I've never tried slidelocker but I'll definitely look into it. – Paul Warnick Sep 27 '15 at 12:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.