0

I use my Nexus 6 for the purposes of developing Android apps, and I have been using my laptop along with my phone to write and test the apps. In the past, I have never had any issues with connecting my phone to my laptop, but as of today, my phone only shows up on my computer when Debug Mode is disabled. When debug mode is enabled and I plug my phone in to my computer, my computer plays the tone that indicates new hardware, but the phone never shows up on the "My Computer" listing, and adb devices does not show it. I have tried rebooting both the computer and the phone, but that has not resolved the issue.

My computer is running Windows 10 Pro x64, and my phone is running Android Lollipop v5.1.1 Build LMY48M.

I do not know if there is any connection, but prior to installing the latest update to Android System WebView from the Google Play store, this worked just fine. The only reason that I cite this as a possible cause to the problem is because after getting this update, my app drawer was updated to look like the Android Marshmallow app drawer which I thought was not going to be released ahead of Marshmallow.

UPDATE: I tried plugging my Nexus in to my machine running Fedora Workstation 22 and it works just fine regardless of whether Debug Mode is enabled or not.

UPDATE 2: Whatever the issue is, it's got something to do with my computer. I tried it on my mom's laptop and it works just fine. She does not have the Android SDK installed, but aside from that, her machine is identical to mine.

  • Have you tried to use a different USB port? Sometimes that is the issue. If not, open your SDK manager and make sure your drivers are up to date. – OPatel Sep 27 '15 at 3:28
  • I tried both of these things and neither warranted any results. Thank you for the suggestion though. – DavidB Sep 27 '15 at 3:30
1

Installing Universal naked drivers shall solve your problem. Assuming you are skillful enough installing drivers manually as you intend to make use of ADB, here's a reference link to Universal Naked Drivers: http://forum.xda-developers.com/google-nexus-5/development/adb-fb-apx-driver-universal-naked-t2513339

It generally supports all Nexus devices(probably all), if it doesn't help, uninstall the current installed driver from Device Manager and replug your Nexus device to make it install its drivers again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.