0

I have yu yureka android device which has octa core snapdragon 615 processor, 2GB of ram, 16GB internal storage.

Recently I migrated to snapshot release of Cyanogen Mod 12.1 (android 5.1) plain without any Google Proprietary Apps.

I thought of using device encryption feature. There is no lock screen password/pattern set. There are no secondary users. There are no so many apps installed. My /storage/emulated/0 doesn't contain any media files (completely free).

So, I entered Settings > Security and selected Encrypt Device . It showed some boot loader icon for a couple of minutes and then Settings > Security showed Device Encrypted.

Is it really encrypted, since it took very little time and not having lock screen password. The device was fine on rebooting.

Then, i created 2nd user and protected it with lock screen pattern. Then rebooted, device was fine.

Then I created lock screen pattern for the 1st user (Owner). It prompted to ask for this pattern at device boot up and I selected Yes. I then rebooted the device. At first, it asked for pattern, I entered the 1st users lock screen pattern. Then the device rebooted and was in boot loop now (continuous boot loader animation) for 45minutes.

  1. Was it encrypting the storage now or the process of encryption somehow corrupted??
  2. Did I not do the encryption correctly? Is it must to have lock screen pattern before starting encryption?
  3. The device is relatively faster and I guess it should not take so long for encryption. With my device specs how long can encryption be??
  4. I have a 32GB external sdcard formatted with fat32. Is it going to encrypt that as well?
  5. What happens possibly if I pull out the battery, apart from loosing data?

Please help..

0

After 2 hours of waiting, I long pressed the power button for 15sec which gives battery pull effect. Then I rebooted to recovery. Tried to format /data sparing /data/media which gave the error unable to mount /data. Then tried formatting /data including /data/media and it was formatted.

Then rebooted and first set a lock screen pattern and then tried encryption. This time, it got successfully encrypted in around 10minutes. The device asked for pattern on every boot, and it takes couple of minutes for every reboot.

So, I think the issue was doing encryption without lock screen password and then adding password later.

0

It seems to be an issue with the rooting. The simple trick I used was to wipe /data, install an AOSP system non-rooted, then do the encryption all over again, then wipe again and reinstall a rooted system from within TWRP. The recent TWRPs come with encryption password support so as long as you can decrypt, you'll be able to reinstall within the mount points (without formatting the whole disk), which makes things a lot easier. You don't really need the stock rom... Just AOSP does fine.

There's a manual command line approach too, but it require tampering with the partition size in text mode, so no I won't do that. ;)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.