1

A few weeks ago, my phone's APN list got corrupted, causing me to lose mobile data; a series of firmware flashes, modem updates, and backups and restores fixed the APN problem, but now the entire sound subsystem is non-functional. The speaker and microphone do not work in any app.

Example symptoms:
Dialer - pops up a "stopped responding" dialog when making or receiving calls; selecting 'wait' in the dialog allows the call to complete, but with no incoming or outgoing sound.
Sound Recorder - pressing record pops up a dialog "Internal Application Error. Microphone may be in use."
YouTube - all videos show "There was a problem while playing. Touch to retry."

Phone details:
Samsung Galaxy S4 (Sprint), model number SPH-L720. Rooted, running Android 5.1 (& 4.4) (CyanogenMod 12.1 various nightlies and 11 snapshot).

Things I have tried (without success):

  • Factory Reset (without restoring backups, just to see if sound works)
  • Re-flash various ROM versions; cm-12.1-20150917-NIGHTLY, 20150922, 20150926, 20150928, and cm-11-20141112-SNAPSHOT-M12-jflte. The 20150917 nightly and 20141112 snapshot versions have previously had sound working, so it's not a bug in new ROM versions.
  • Combinations of the re-flash with factory reset.
  • Reboot with SIM card and micro SD card removed.
  • Re-flash modem/baseband to earlier version (was running OH1, now running NAE; have not flashed all the way back to MF9, which is the version that was running the last time I'm sure sound worked, but this was a move of desperation, since the modem firmware shouldn't impact the sound system.

I'm at my wits end. I feel like with the above, I've re-initialized every location that could possibly be affecting the sound system, and yet, I can never get any audio input or output from the phone.

2

Providing what worked for me, in case someone else has the same problem:

A helpful suggestion over at xda-developers.com by developer bilgerryan indicated I should Odin a full stock ROM, in order to replace whatever corrupted data was causing the problem. Long story short, in the process of looking for progressively "fuller" stock ROMs after several failures, I ran across this thread, which provided a tar which "contains the NON-HLOS.bin modem.bin sbl2.mbn tz.mbn aboot.mbn rpm.mbn sbl3.mbn".

Flashing that tar fixed the problem completely, and since it doesn't touch the system or data partitions, it didn't require backing up or restoring anything. (Although you should always back up your data before flashing anything, just to be safe.) After that, I re-updated the NON-HLOS.bin and modem.bin to the further updated versions I had installed when sound wasn't working, and it continued to work. So the problem was in one of: tz.mbn aboot.mbn rpm.mbn sbl2.mbn sbl3.mbn

Huzzah for having a working phone again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.