0

I am helping my girlfriend to connect her Samsung Galaxy Ace Plus S7500 with a new android account. We set the phone to factory settings and are now trying to connect a(!) google account to the android phone. Both google accounts, the new AND the old one cannot connect via the settings.

The funny thing:

Logging into gmail with the new google account via the pre-installed browser works nicely. However connecting via settings>accounts and synchronization does not work and the error message is: Wrong username or password, even though the user credentials are the same as logged in via the browser. Furthermore, we have checked the password multiple times via copy and paste of the password.

Here are the details:

Android Version: 2.3.6

Kernel Version:

2.6.38.121500
dpi@DELL203 #1
Tue Nov 20 00:04:25 KST 2012

Buildnumber: GINGERBREAD.BULK1

My add account screen looks like that:

enter image description here

Btw we are connected to our home WIFI, while doing this!

I really appreciate your reply if you have any idea, what also can be tried!

UPDATE

As explained in this thread: Cannot connect my Galaxy Ace to my Google account

I changed the date to 21.November 2015 and get a new error:

'Can't establish a reliable data connection to the server.'

I also tried to log into my gmail app, but the login failed as I get the same error again:

'Can't establish a reliable data connection to the server.'
  • See if the answer here is of any use to you: Unable to Setup Google Account on Android 2.3 – Firelord Sep 30 '15 at 19:29
  • Does the account have two-factor authentication enabled? – eldarerathis Sep 30 '15 at 20:09
  • @eldarerathis yep the two accounts have two factor authetification. And the phone number goes to the same phone. – Kare Sep 30 '15 at 20:12
  • I don't think Gingerbread supported 2FA properly. I think you need to use an app-specific password for it (I have no way to test this, though). – eldarerathis Sep 30 '15 at 20:48
2

problem happens when 2-step verification enabled to google account. to solve this first of all disable 2-step verification method if possible, then try to do so-

  • on username write as

    username@gmail.com

  • make sure your password is correct (maybe)

see https://www.google.com/settings/security/lesssecureapps

  • 1
    Rather than disabling the 2-step verification, an alternate one time password can be produced. Google allows creating app passwords. – Firelord Sep 30 '15 at 20:48
  • actually it worked for my device.. may be the device or operating system doesn't support OTP option. – Vipin Sep 30 '15 at 20:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.