2

I have a mobile phone with a dual-sim slot and I inserted a SIM in each of them.One of the SIMs get logged in in national roaming which is ok as there is a cooperation between my native service provider and the "foreign" one. I use a separate app (Roaming Control) to handle roaming correctly.

If now I am logged in in the foreign net and I call out to anybody I get a message, to confirm using roaming and not the secondary SIM which is in its native net:

Roaming warning

The SIM card that you are about to use is now in roaming. Would you like to continue?

I have to confirm manually which is no problem as long as I have the phone in my hands.

If I am sitting in my car and I use a voice dialer this is nasty: The call does wait for the entry of my decision but does not show the question as the display is in general turned off beforehand. Thus I have to wait for the ring tone and if it is not coming I have to take the phone in my hands (!) and confirm the roaming.

Is there a way to disable this warning?

  • Is there an option "Show roaming reminder" under "Settings -> Sim management -> Roaming"? My answer here may be helpful here: Modify settings parameters through database – Firelord Oct 2 '15 at 12:09
  • @Firelord Please write your comment as an answer. I tried it and this was the setting to change. Then I can accept the answer. – Christian Wolf Oct 6 '15 at 8:13
2

In my Android 4.2.1, I have to set Settings → SIM Management → Roaming → Show roaming reminder → Never.

Alternatively, use to disable the notification for a particular SIM.

Setup ADB in PC, enable USB debugging in device, connect the device into PC, launch a shell on latter and follow these instructions:

To enable data roaming for default SIM, enter:

adb shell settings put global data_roaming 1

Changes would take effect immediately. For SIM2, change the key to data_roaming_2.

If you want to know the details about this command, enter adb shell settings. You would easily come to know what the aforesaid command would do.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.