For some reason that completely escaped me, this here Samsung S3 mini stopped connecting automatically to my home network, always requiring me to re-type the wifi password.

Since then, I noticed that it's not just for my home network, but for all wifi networks.

More concretely, here's a sample of what happens:

  • I try to connect to a WPA-protected wifi.
  • Android asks for the password.
  • After I provide it, the phone connects successfully.
  • I turn off the wifi (on the phone).
  • I turn it back on.
  • The phone doesn't auto-connect to the wifi.
  • I explicitly select the wifi network to connect to.
  • Android again asks for the password I typed in a minute earlier.

Any idea how that can happen? What could I have done to deserve this? What could I do to redeem myself and fix this problem?

More details: "forget"thing ("disconnect"ing from) the network explicitly makes no difference (it still doesn't remember the password next time around), rebooting the phone neither. This phone is running Android-4.4.2, is not rooted.

  • You can consider factory reset, but that always seems to be an extreme option. Did you consider forgetting a network and then attempt to add it in device? How did it go when you then disconnect from that network? Did the problem persist? Is the Android rooted? Which Android version are you using?
    – Firelord
    Commented Oct 4, 2015 at 11:31
  • @Firelord: Right, I'm not looking forward to a factory reset, indeed. I added further details in my question, in case it helps someone to figure it out.
    – Stefan
    Commented Oct 5, 2015 at 22:39
  • When it asks you for password, the second time, the place you type your password has (unchanged) greyed out? A screenshot when you try to explicitly connect would help.
    – Manu
    Commented Oct 7, 2015 at 1:50
  • No, the password field is simply empty. Also, when I click on the network to connect to it, I'm not offered "forget" among the options (I can only "connect" or "cancel"), contrary to the usual behavior. Similarly, in the list of networks, the network is only annotated as "Secured", IOW as a completely new/unknown network.
    – Stefan
    Commented Oct 7, 2015 at 3:35
  • could you include the full logcat log while this problem occurs? Otherwise I highly doubt nobody will be able to help you. android.stackexchange.com/questions/14430/… Commented Oct 7, 2015 at 15:24

2 Answers 2


There is most likely a problem with the phone's /efs/ss_data file. I think it's basically a key for decryption of your Wi-Fi passwords and other things in secure storage.

Root is required for this fix.

First we need to confirm it's a problem with secure storage.

  1. Install BuildProp Editor from Play Store

  2. Set ro.secure.storage=false

  3. Reboot, setup Wi-Fi & reboot again

WiFi should now remember passwords if there was an issue with secure storage.

Now let's fix the secure storage issue since we know what's broken.

  1. Set ro.secure.storage=true using BuildProp Editor

  2. Backup EFS using TWRP/CWM recovery

  3. Delete ss_data in /efs using ES File Explorer in root mode

  4. Reboot, setup Wi-Fi and reboot again

Your Wi-Fi passwords should be remembered now on any ROM/kernel, non rooted and without edits to build.props

Tested ON: Samsung Galaxy S6 SM-G920T1 MetroPCS Variant on 5.1.1 build DOJC

Note: This may work on other devices that require setting ro.secure.storage=false in build.prop for Wi-Fi to remember passwords. I have seen users with Nexus devices experiencing this issue as well.


  • Can you tell us on which Android version and device is your answer tested upon? Furthermore, can you link this root file explorer?
    – Firelord
    Commented Mar 17, 2016 at 12:07
  • I tested this on a GS6 5.1.1.
    – Geofferey
    Commented Mar 18, 2016 at 22:12
  • FWIW, I do have a /efs but it doesn't contain any ss_data. And my grep secure /system/build.prop returns nothing.
    – Stefan
    Commented May 31, 2016 at 0:31

Google Backup Transport service may have screwed up, failing to update the wifi passwords being stored on their servers (methinks it is pulling down a blank password over and over again). In Settings -> Apps -> All look for Google Backup Transport, clear cache and data, and restart the phone.

  • I just tried it, but the behavior is unchanged. FWIW, the option "back up my data" (to backup data to Google servers) is disabled.
    – Stefan
    Commented Oct 9, 2015 at 1:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .