1

There is no USB options when I connect to pc. I have tried a Galaxy Avant phone with the same cable and works, so it is not the computer or the cable. I have turned off and on USB debugging. I have tried so many " solutions" and still nothing.

Phone: Rooted Galaxy Avant (T-mobile) Kitkat 4.4.2

  • sorry if i misspeled something XD – ThatGuy Oct 2 '15 at 15:11
  • If you notice any of youre own, you are free to edit your own posts. Just click the 'edit' link under the tags. – wbogacz Oct 2 '15 at 15:16
  • Try changing the device connection protocol. My device only works in ptp. – Ethan Z Oct 2 '15 at 16:11
  • @EthanZ hey m8, thanks for responding so quickly. Could you tell me how? Im kind of a big noob. :) – ThatGuy Oct 2 '15 at 16:49
  • It should cone up as a notification when the device finds a computer, bit there may be an override method in the dev settings – Ethan Z Oct 2 '15 at 17:29
1
  • First of all, please make sure that you have latest Samsung USB driver installed on your computer, if not please update it or download latest version from this page.

  • Second, make sure that USB cable is working properly.

  • Third, if USB cable is ok, driver is up-to-date and you still won't able to connect, then type in your Phone app this string *#7284#and check the option MTP + ADB, press save and reset. This should solve connection issue.

P.S. If appeared *#7284# "service screen" is different which means you can't see the MTP + ADB option please post the screenshot here.

  • Still nothing m8... idk I am probably missing something very obvious. – ThatGuy Oct 3 '15 at 2:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.