20

Under SettingsWireless and networks, USB internet will not highlight nor will it let me activate it. Therefore, I can't connect my smartphone to the PC.

Is there an alternate way to check why this is occurring and fix it?

1
  • 1
    Please make sure your data cable is functioning properly. There are also some USB cables that are not for data use. Perhaps try a different cable. Please also specify your device/OS/PC OS.
    – paulmz
    Commented Oct 5, 2015 at 13:56

12 Answers 12

15

I wrestled with greyed-out USB tethering for 3 days. I factory reset, changed VPN settings (when for an unknown reason I lost data capacity), read all the forums, etc.

It's embarrassing. Despite having a $40 metal-braided, multi-tipped cord with amazing mall-metal jacks that works for charging, for tethering it wouldn't. Trying the $3 cord I had the same effect, I discovered it was the cord. That's all.

The expensive cord obviously isn't made to do anything but charge, and the cheap factory cord was simply defective. (When I wiggled the wire where it goes into the hack, my phone beeped and all the charging/tethering options appeared.)

That whole time it was the cord, poorly manufactured or damaged.

Try a brand new cord. It's likely just that. (My defective cord was only 1 day old!)

1
  • In my case it was a matter of unplugging, rotating the plug 180 deg, and plugging back in.
    – DarenW
    Commented Aug 19, 2023 at 17:27
5

When "Data saver" is turned on, USB Tethering is not allowed. Turn it off and you may be able to USB Tether (Android AOSP 7.1):

  1. Settings
  2. Data usage
  3. Tap "Data saver"
  4. Tap "Off" to turn it on.

You're steps may be different, you know the OS guys like to move the cheese.

1
  • And apparently as I found out, not all USB type-c cables that advertise themselves as DATA cables will allow USB tethering Commented Apr 23, 2019 at 4:56
3
  1. Unplug the USB.
  2. From Settings > Developer options, enable it by switching the "on" option at the top.
  3. Connect the device with USB.
  4. When asked, choose "MTP".

The USB tethering option will be available.

Tested on Sony Xperia C4.

0
1

I faced the same problem of USB tethering option being disabled when I updated the software on my Samsung Galaxy On5.

The solution was simple though.

When you connect your phone to the PC with a USB, a message will pop up on your phone "Allow access to device data - An MTP connection will be established to access the data on the connected device - DENY ALLOW " (Please note this message did not pop up prior to the software update...which means the phone was directly connected to the PC via USB)

When you select the ALLOW option on this pop up, then only the USB tethering option will be available for selection. If you select DENY, the USB tethering option remains disabled.

1

I was using a USB connection on the front of the PC house, it seems it's only connected with power because the phone didn't connect to it. As soon as I plugged it in to the back of the house onto the motherboard's backpanel, everything worked.

1

I had the same question (but I didn't have carma to post the answer), now i have and I'm going to copy my question+answer (the original ones are here)

For years I used my phone (with Android v12) as a backup connection to the internet (and you know - airports...). Today I connected my phone to the laptop with my factory-default cable and tried to enable tethering - but the USB Tethering button in the menu was disabled.

I checked the cable (several), and I use one that does the trick with another phone.

So it turned out that I needed to dance around the phone a little. Maybe the menu items on your phone will have other names.

1. enable "Developer options"

In two words: Settings > About device > Version and here tap "Build number" several times.

Or google this: android YOURBRAND enable Developer options

2. reset default USB settings

Settings > System settings (at the bottom) > Developer options > Default USB configuration

I had "No data transfer" there, I changed it to "USB Tethering"

And also check the neighbor menu item Select USB configuration, my default value was "Charging", so I changed it to "RNDIS (USB Ethernet)"

Now disconnect-connect the cable, and it should work

original answer

1
  • This fixed the problem for me on Moto g14 with Android 13. Thank you Commented May 30 at 7:31
0

I called up MI Customer Care, and this is how it worked out for me.

  1. Install the latest system update
  2. Go to Installed Apps> System Launcher> Clear Data and/or Clear Cache
0

Simple, gray means connection error (any how).

In my case,

  1. Connect my PC & smartphone by a USB Cable.
  2. Under Setting>Tethering & Mobile Hotspot>USB Tethering check the radio button.

That's it.

0

This turned out to be a hardware issue. Tried a couple of cables, but they were all the same. After removing the phone from its case and blowing in the connector and trying again it showed up. Presumably the charging pins were OK but there was some crud on the data pins (or maybe the case was not letting the plug go all the way in).

0

For me, I had to use a USB-C to USB-C cable, as it wouldn't work for me trying to connect my Galaxy S20+ USB-C to a USB-A port.

2
  • As it’s currently written, your answer is unclear. Please edit to add additional details that will help others understand how this addresses the question asked. You can find more information on how to write good answers in the help center.
    – Community Bot
    Commented Jan 28 at 21:56
  • Its just your cable that was faulty. Some cables are power only, some are data only and some are both. Commented Jan 29 at 0:13
0

USB-C (what many Androids use to charge now) is double-sided - you can plug it in either way and you'll be right.

But USB-A is not double-sided, so often, a USB-A to USB-C cable only works one way. It can help to mark the side that does work with a sharpie.

-1

For people still looking for the answer, connect the USB cable to the PC. This enables USB tethering and it longer is greyed out. Hope this helps.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .