0

I have Micromax A114 Canvas 2.2 and I change its ROM every time I'm bored of the existing one. But this time, when I changed ROM of mobile and tried booting it with Note 4 ROM (though it is not Note 4) which upgraded my Android 4.2.2 to 4.4.4., Google apps do not work here and giving this error

<Application Name> relies Google play services, which is not supported by your device. contact the manufacturer for assistance".

I have tried upgrading Gapps for 4.4.4 and also installing version which is compatible for 4.2.2 but it does not solve my problem.

Can someone please help. I don't want to change this ROM because I'm liking it for now.

2
  • I'm guessing that ROM just isn't compatible. Sorry.
    – Ethan Z
    Oct 5 '15 at 10:48
  • Rest of it is working just fine apart from the google play services. Even when i stopped play services it stopped prompting with the error but the some google applications are not working. Oct 5 '15 at 11:07
0

You may install any unofficial version of ROM made for your device, but you cannot expect everything to work.

If you really want newest Android version on your mobile, you may forward your request to the device manufacturer, which in your case is Micromax.

The Google Apps packages for particular Android version doesn't mean they work on every device with the appropriate Android version. They can be guaranteed to work on devices that pass the CTS. On such devices, if a bug like you have encountered occurs, you can file a bug report.
There is nothing much you can do to make Google apps work.

Alternatively, you may use the last Android version that your manufacturer released. Google apps on almost all devices get auto updated to the latest versions, and you wont encounter any such force close issues.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.