I upgraded my Nexus 5 from Android 6 preview 3 to the 6.0 final version by manualy flashing image files from google factory image. All my applications lost permissions and crashing. I am unable to give permissions through settings too. The only solution I found so far is to reinstall applications. However I don't want to reinstall all of them for obvious reasons.

Please advise how to fix it.


For me the boot.img modification by Chainfire worked partially: device seems to be rooted (with supersu 2.51 beta), but twrp asks for password and cannot mount anything (I've posted a question about the latter). In particular I could not install supersu via adb sideload from recovery, as Chainfire recommends. Rather I just installed apk from system (using simple explorer).

| improve this answer | |
  • Sorry, could you clarify if this answer solve OP's problem? (particularly, about restoring apps permissions). I don't see if OP has any issue with flashing, and I didn't have this issue after flashing, so I'd like to know if flashing & rooting will help to solve OP's problem. – Andrew T. Oct 9 '15 at 2:23
  • @AndrewT. I've posted this because of the comment to Andi's answer - Sergey asks for a working root which is required for that answer to work. In fact I believe the source of OP's problems is that Marshmallow blocks root access (among other things). – მამუკა ჯიბლაძე Oct 9 '15 at 6:19
  • Thanks @მამუკაჯიბლაძე. I managed to root with the guide. TB reports errors though during restore, so I am not sure if the solution works. – Sergey Oct 10 '15 at 20:35
  • @Sergey As I discovered today (see this answer to my own question), Chainfire's instructions do not mention one important step: after booting into recovery, one must wipe data. Did you do this? – მამუკა ჯიბლაძე Oct 10 '15 at 20:57
  • 1
    @მამუკაჯიბლაძე That wiping seems to be related to forceencrypt on Nexus 6, 9 and newer devices. Not relevant to Nexus 5 – Sergey Oct 11 '15 at 9:31

I had the same problem. For me the following helped (root needed):

  • backup the app with Titanium Backup (TB); its an app available in PlayStore
  • restore it immediatly with TB
  • done (no uninstall needed; app data wont be affected)
| improve this answer | |
  • Can you recommend a working root for 6.0? – Sergey Oct 6 '15 at 19:41

Flashing factory image solved the issue. https://developers.google.com/android/nexus/images

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.