0

I'd like to use the Cerberus shell to input commands like taps, swipes, and text. I know how to do it using the command line and ADB shell, but I don't have USB debugging enabled on my Nexus6, so I'm trying to do it using Cerberus. I was under the impression that the same commands should work, but they don't seem to be.

I tried sending "input keyevent 26"; it sends, but nothing happens on my phone (the screen should turn on). I also tried "adb shell input keyevent 26", but it just says "error: device not found".

Am I doing something wrong? Or is this something the Cerberus shell can't do?

Background:

I've got a Nexus 6 with a broken screen: no display and no touchscreen. My goal is to run the app SMS Backup and Restore so I can backup my texts before sending in my phone to be replaced.

I don't seem to have USB debugging enabled (though I thought I did -- I reinstalled the OS a few months ago) -- when I type "adb devices," the result is blank.

I can use the ADB shell to input taps, swipes, and text/numbers to my Nexus4. I think I could blindly use the SMS Backup app by inputting the proper sequence of commands into the Cerberus shell. (Or, maybe even easier, just use the shell to get my phone to cast to my tv or Chromecast; then I could use a OTG mouse.)

  • ADB means Android debugging and you can debug the Android if only the USB debugging is enabled in the device. Since it is not, attempting any ADB command is futile. – Firelord Oct 6 '15 at 12:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.