I just flashed the Android 6 Image to my Nexus 7 (2013) LTE a few minutes ago. It was a clean flash, so I copied my files over to my PC.
When I plugged it in after it booted, Windows detects it, installs the drivers automatically and shows the device in My Computer. From it's icon, It's in MTP mode. But when I open it, I can't see the usual "Internet Storage" disk that lets me access my files. The device shows a blank folder.
I searched the Settings app for "MTP" & "PTP" but found nothing. (Unlike in Lollipop) In the "Storage & USB" section also, there is no mention of a USB connection other than in the title.
I can't swipe down the notification area while the device is plugged in because the screen is broken (I use a mouse)

What might be my problem?
PS: The device has an unlocked bootloader so I can edit system files.

Thanks.

up vote 10 down vote accepted

Go into Developer options, and cycle the USB host mode, the files will show up on my PC.

  • what do you mean by "cycle"? I've tried putting it to charging, back to MTP, and various permutations, including power cycling, but I can't see anything from by desktop. This used to work before Marshmallow, and I never get anything in the notification area (maybe I added a harsh permission? Don't know what to whitelist now.) – fommil Dec 24 '15 at 0:38
  • 2
    The answer means to go to Settings > Developer options, and turn "USB debugging" off and back on (= cycling). I had issues getting MTP working after a Marshmallow upgrade until I did this too. – Laogeodritt Dec 28 '15 at 1:51
  • 3
    Doesn't fix the issue. – BrainSlugs83 Aug 3 '16 at 18:32

You can swipe down the Notificationbar and it will show Charging only. If you click that entry you can select the desired mode. The selected mode won't be set as default, so if you plug your device again, it will be on Charging only again.

To set the default mode you first need to enable developer mode (don't ask me why...). This can be done by going to About phone settings and clicking on the build number a few times.

Then go to the now accessible Developer Settings -> USB-Configuration (should be under the Network section). This should be set to the desired mode. In my case it was allready set to MTP (the desired mode), so i had to set it to another mode (for example Charge only) and then set it back to MTP.
Hope this helps!

EDIT: This only seems to work once. So if you disconnect and reconnect the device 2 or more time, the default is again on "Charge only". It is mentioned in the changelog of Android 6. Link-https://developer.android.com/about/versions/marshmallow/android-6.0-changes.html#behavior-usb

  • 3
    Right, you have to do this EVERY SINGLE TIME, sometimes it still won't work, dumbest shit ever. I think I'm gonna stop updating my Android from now on, after every single update lately, something ends up breaking. I also lost my Google Now launcher with this update as well. – Hank Nov 11 '15 at 20:53
  • @Hank i am not sure, if they will even correct this issue... It seems like it is a known issue since they released the preview. What i really can't understand, is why they put this (not working) function of choosing the default behavior into the developer options... – Springrbua Nov 12 '15 at 9:24
  • Exactly, and why don't they tell you about all the changes they are making BEFORE making them? I had to look online and find out for myself that I'll have to manually download Google Now from the Play Store to get back what used to be one of the stock functionalities of the device! WTF? – Hank Nov 12 '15 at 15:20

USB Mode: Set Default to MTP (file transfer) Marshmallow/6.0

Default is set to Charge only mode, You can enable developer options and enable MTP feature by following below steps:

  1. Settings -> About phone -> Touch 7 times on Build Number to enable Developer options
  2. Settings -> Developer Options -> Select USB Configuration -> MTP
  • 5
    oops this only works one time...so this suggestion does not fix the problem – Louie Oct 12 '15 at 5:34
  • exactly that would be Settings -> Developer Options -> Networking -> Select USB Configuration, the number of options keeps increasing, hard to find one – mikus Feb 1 '16 at 13:24

Swipe down the notifications window with the device plugged into the computer, there should be a persistent notification for USB Mode, make sure it isn't set to "Charging Only". I had this on my Nexus 6 after a clean flash of Android 6.0 as well. I've seen others report this as well.

  • The thing is, I can't. The screen is broken. I can only attach either the mouse or the other end of the cable from the desktop, not both. Can I do this by editing some xml file or the like on the device? – Rhaegar Oct 6 '15 at 15:43

protected by Community Nov 2 '15 at 16:52

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.