This question follows up on Boot loop after flashing Android 6.0 Marshmallow on my Nexus 5 (but there are many other posts about this topic on the web, see this Reddit post and this XDA Developers post).

I just want to approach this problem in a more structured way as opposed to just saying how something worked by coincidence.

Problem definition

Like everyone else, I simply followed the official instructions from Google developers. To expand a bit (because this could be the cause of the problem), following this part of the instruction from the above link:

To flash a device using one of the system images below (or one of your own), you need the fastboot tool. You can get the fastboot tool either:

  • From a compiled version of the Android Open Source Project.
  • Or, from the platform-tools/ directory in the Android SDK. Be sure that you have the latest version of the Android SDK Platform-tools from the SDK Manager.

So I simply downloaded the entire Android Studio application (I know that's a bit of overkill but I just wanted to make sure I got the latest and greatest).

From the below Android Studio screenshot, you can see that I have Android SDK Platform-Tools 23.0.1.

Question: I'm updating my phone from Android 5.0.x (not sure what the exact version is). Could it be that this Android version mismatches the Android platform-tools that I have?

I've ensured that my fastboot is added to my PATH environment:

$ which fastboot

I've downloaded the flash file (specifically the hammerhead for Android 6.0.0 (MRA58K)), then I started the device in fastboot mode by the key combination, and ran the flash-all script.

What happened was that the script ran with the following logs:

$ ./flash-all.sh 
sending 'bootloader' (3120 KB)...
OKAY [  0.207s]
writing 'bootloader'...
OKAY [  0.524s]
finished. total time: 0.731s
rebooting into bootloader...
OKAY [  0.001s]
finished. total time: 0.001s
sending 'radio' (45425 KB)...
OKAY [  1.536s]
writing 'radio'...
OKAY [  3.145s]
finished. total time: 4.681s
rebooting into bootloader...
OKAY [  0.001s]
finished. total time: 0.001s
archive does not contain 'boot.sig'
archive does not contain 'recovery.sig'
archive does not contain 'system.sig'
Bootloader Version...: HHZ12k
Baseband Version.....: M8974A-
Serial Number........: 03a3d66d0a4e64bd
checking product...
OKAY [  0.100s]
checking version-bootloader...
OKAY [  0.100s]
checking version-baseband...
OKAY [  0.100s]
sending 'boot' (9156 KB)...
OKAY [  0.500s]
writing 'boot'...
OKAY [  0.798s]
sending 'recovery' (10016 KB)...
OKAY [  0.562s]
writing 'recovery'...
OKAY [  0.850s]
sending 'system' (1019261 KB)...
OKAY [ 32.164s]
writing 'system'...
OKAY [ 70.421s]
erasing 'userdata'...
OKAY [ 15.854s]
erasing 'cache'...
OKAY [  0.630s]

finished. total time: 122.480s

Question: should I be concerned about this part?

archive does not contain 'boot.sig'
archive does not contain 'recovery.sig'
archive does not contain 'system.sig'

Anyways after all is done, the phone reboots and gets stuck on the boot screen (forever).

What I've tried

I've tried running these commands as suggested by this post

adb shell
e2fsck /dev/block/platform/msm_sdcc.1/by-name/persist


make_ext4fs /dev/block/platform/msm_sdcc.1/by-name/persist

but nothing changed.

I've also tried performing a wipe using TWRP as suggested by this post:

  • I downloaded the twrp- file from the twrp site

and then ran

fastboot flash recovery twrp-

then performed a wipe two different ways:

  • performing a normal wipe pretty much made things worse. The phone would show the Google logo then reboot, show the Google logo and so on.
  • simply deleting the cache also didn't make any difference at all.

I'm stuck. Any suggestions?

1 Answer 1


I too faced this issue and issuing the fastboot commands manually (instead of relying on flash-all) and it worked well.

These are the commands to use (just forget everything and make sure these commands are executed in this order with the appropriate .img file available):

fastboot flash recovery recovery.img
fastboot flash boot boot.img
fastboot flash cache cache.img
fastboot flash userdata userdata.img
fastboot flash system system.img
fastboot reboot
  • mmm.. i just tried that.. it seems to still be stuck on that load screen.. how long did it take before it finally booted properly for you?
    – abbood
    Commented Oct 7, 2015 at 6:54
  • it actually worked! it just took it a bit to reboot (tip: how do you know that this time it will work? i noticed that the screen wasn't as dimmed as those times it usually fails.. also i advise you not to wait for it.. put your phone somewhere else and go on with your business)
    – abbood
    Commented Oct 7, 2015 at 9:36
  • Yeah, sorry to leave you to find it yourself. It took me more than five minutes to cross the marshmallow boot animation.
    – Narayanan
    Commented Oct 7, 2015 at 9:51
  • 2
    Thanks guys. By the time I got this far reading the thread the startup finished successfully. :) Commented Oct 8, 2015 at 11:42
  • 1
    @Narayanan if you just type '@' into the empty comment box, it should offer to complete it for you. Other than that, copy & paste...
    – derobert
    Commented Oct 11, 2015 at 9:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .