As per the rule with a new Android, I have tapped build number 7 times for enabling Developer option. However, USB debugging is shown as greyed out and I cannot start it. Samsung Galaxy J5 comes with latest Android 5.1.1. I have also updated the software to latest version.

Can anyone suggest me what to do?

Here is a screenshot:

(Click image to enlarge)

IMG: can't start usb debugging


OK, here is I got the solution! there wasn't any bug or error in Android. It is because I have installed Samsung My Knox in my phone. Knox give an extra protection to device and also for some security reasons, Knox disabled USB debugging.

according to Samsung My Knox :

If you are using My KNOX, you cannot enable USB debugging mode while the container is installed.

I have uninstalled Knox and now USB debugging is working properly!

There is another application named Samsung Knox Express which give you option for enabling USB debugging, but only System Administrator can install this application.

| improve this answer | |

This worked for my Samsung Alpha: Enter *#0808# in your phone's dialer. A new screen will pop up. There, select "MTP+ADB" option and tap OK.

(Click image to enlarge)


| improve this answer | |
  • are you using MY Knox @user2685557 ? because it is not working in Samsung Galaxy J5 with MY Knox installed. – Mihir Joshi Jan 25 '16 at 9:22
  • Yes Knox is installed in my device. After connecting the device to USB, dial *#0808# and see again if its (MTP+ADB) only. If not then select it and press OK. In my device whenever USB is unplugged, it resets to (MTP) option. – user2685557 Jan 26 '16 at 12:15
  • It's not working in my phone. After selecting MTP-ADB it's saying Ok but when I run app in Android Studio, my phone doesn't appear. – Mihir Joshi Feb 1 '16 at 8:46

Try revoking the usb debugging authorisations. Then turn off developer options and restart your phone. Once your phone has turned on, enable developer options and then see if you are able to enable USB debugging

| improve this answer | |
  • No.... I'm still unable to do that... :/ – Mihir Joshi Oct 8 '15 at 6:18

Not the answer you're looking for? Browse other questions tagged or ask your own question.