0

After flashing TWRP and booting it (situation described in title), TWRP asks for password. When I bypass it, TWRP cannot mount anything. When I reboot to system, it is stuck at the startup animation forever. Only can boot when I reflash stock recovery. Actually I have to reflash system too, it cannot boot otherwise.

I also tried boot.img replacement by Chainfire, result is exactly the same.

Has anybody successfully rooted Android 6 at all? What was the procedure?

Update Just installed apk for supersu 2.51 (beta) and it seems to work - at least adb now goes root (could not before). However twrp still asks for password and cannot mount anything.

2

Worked for me like this:

  1. Boot into Fastboot
  2. Flash Chainfire's WIP boot.img
  3. Flash TWRP
  4. Copy latest SuperSU BETA onto a USB stick
  5. Use an OTG adapter to connect that USB stick to your Nexus 9
  6. Boot into TWRP
  7. Tap "Cancel" at the password prompt
  8. Mount the USB stick
  9. Install the SuperSU.zip from USB
  10. Reboot

I didn't have to install stock recovery or anything else. It booted up just fine with all data still there.

  • Sounds much better! So you do not need to wipe data? – მამუკა ჯიბლაძე Oct 12 '15 at 4:39
  • 1
    No, you only have to wipe if you want to disable encryption. But for rooting only, you don't need to. – mbirth Oct 13 '15 at 8:02
0

Even I went into the same problem but finally I fixed it.

The reason why your phone gets stuck up on the start page is because android phones with lollipop and above version needs to unlock the boot loader to gain the privileges. This was implemented by google for the purpose of factory reset protection.

To do so you need to enable the OEM Unlocking check box in Developer Options.

This is what I did and i finally rooted my device using TWRP recovery. If it doesn't work try installing the latest version of SuperSu.

  • In my case that was not the reason since my device was unlocked when this happened. On the bootloader screen this is explicitly declared. – მამუკა ჯიბლაძე Oct 11 '16 at 4:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.