4

Last day I got the notification to download and install official Android 6.0 Marshmallow in my Nexus 5, which is not rooted, was running Android 5.1.1 and no custom ROM. As I downloaded and installed it, from that point its gone to boot loop state (the four dot animation is endlessly running).

I have already searched the web for solution like Boot loop after flashing Android 6.0 Marshmallow on my Nexus 5, Boot loop after flashing android 6.0 marshmallow on nexus 5 follow up and many more, but not tried. Because all those help seekers had tried to manually OS install or phone was rooted or already had custom ROM, but my Nexus 5 did not have any of those.

I had tried "wipe cache partition" and reboot, but it did not helped. As I don't had any data backup of my phone storage, the last thing I will be willing to do is "wipe data/factory reset". As my phone's usb debugging was enabled and I had adb in my desktop, so I have also tried to copy data from my phone using the "adb pull" command in boot looped mood. But also did not got any luck, may be "adp pull" command don't work in booting mood or I am doing something wrong with the command.

Any help to backup/recover the data or solution of the boot loop problem without "wipe data/factory reset" is appreciated. Thanks in advance.....

  • Do you have a custom recovery? – Thomas Vos Oct 14 '15 at 7:09
  • no I have not tried any custom recovery yet. but I have tried flashing 5.1.1, but it also remains in boot loop state..... – Ashiq Oct 14 '15 at 19:19
1

If your device is in a boot-loop you will not be able to pull anything. You might want to try and booting the phone into bootloader IF possible by pressing volume down and power to power on the device. I would recommend downloading the factory image from Google, extracting it and trying:

fastboot flash bootloader bootloader-hammerhead-hhz12k.img

To flash the bootloader image in in the zip via the command line, as well as boot and radio just to be safe. DO NOT FLASH userdata.img or cache.img, or run any flash all batch or script as this WILL erase everything that is currently on your device.

OR:

You can try to follow the same instructions to boot to bootloader and:

fastboot flash recovery twrp-2.8.7.1-hammerhead.img

To install TeamWin Recovery, which you can download here. This will give you a custom recovery you can then boot to and possibly be able to adb pull from there.

Hope this helps!!

  • Sorry, can't try this now, as fastboot is not enabled in my phone. Enabling fastboot will erase all my data, which I will consider as the last solution. – Ashiq Oct 10 '15 at 3:05
0

After trying many things I was not able save my data and also had to root my device. Normal flashing didn't help also. I had the problem of persist partition. The life saver was this thread on XDA Developers, where I found my device's problem and solution. The thread link was found from this question. Thanks to the thread writer.

  • Could you summarize the solution here? Link-only answers are discouraged since they become useless if the linked site goes down or (re)moves the content. – Matthew Read Nov 2 '15 at 16:15

protected by Community Nov 1 '15 at 17:45

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.