3

On my Kyocera Hydra phone (model number c6725) running Android 4.4.2 on Virgin Mobile. When I start Gmail (although notifications from gmail work) I'll get the message "Unfortuantely, Gmail has stopped". If I click "report" I then get the message "Unfortuantely, Google Play services has stopped" with only an "OK" option.

When this first happened, I cleared the cache and data for both Gmail and Play services and I was able to open Gmail again, but now that doesn't seem to work. Worse, I noticed the problem also happens with the YouTube app, Play Music and Play Games.

Any idea what the root cause might be and how to fix it?

Edit: This seems to be getting worse and has now started effecting maps making it crash when I try to do turn-by-turn directions. This moves it from annoyance to a real problem. It seems if I uninstall updates to everything Google related (play services, gmail, play music, play games, play whatever) and go back to factory versions it'll work for a while (until it forces it's updates back on and starts acting up again).

Update: According to this on Android Forums, Kyocera are now testing a long overdue fix. Tweet them and you might be able to get it for testing. For my phone, maps has completely stopped working altogether now and I had to install an alternative mapping app (I'm trying out Here Maps right now). Gmail is only not broken by virtue of an update needing more permissions, so it's blocked from updating for the time being (and still works).

  • Is suggest to to uninstall updates from Google Play Services and reinstall it from Google Play. – Thomas Vos Oct 13 '15 at 10:48
  • @SuperThomasLab: I just tried that and it doesn't seem to help – Matt Burland Oct 13 '15 at 18:50
  • I spoke with Kyocera last week thinking it was just my phone and was told by the warranty dept it's a known issue. He told me they wouldn't warranty the phone on it because their new update should fix it. Problem is that new update already came Monday and still not fixed. So i know that doesn't help cuz it but it helps to know you aren't alone. Haha – Katy Morris Oct 27 '15 at 6:50
  • Thanks. Good to know it's not just me. I haven't seen any system updates yet, but I'll keep an eye out. – Matt Burland Oct 27 '15 at 10:34
1

Ryan Radford found a fix for this. Kyocera forgot to include libpredtm.so in system/lib, which causes these crashes. Ryan took the time to upload his copy and another user posted his fix on Android Forums. You need to root your phone then add Ryan's libpredtm.so to system/lib. That's it.

  • Great find. Thanks for that. Not sure if I want to muck about rooting my phone or just wait a few days and see if Kyocera and/or Virgin Mobile fix the damn thing themselves. – Matt Burland Oct 28 '15 at 13:42
  • I tried the rooting solution (impatience got the better of me) but, for whatever reason, ES File explorer wasn't able to give me root access to copy the file. Not sure why. So I gave up again. Virgin Mobile's support was pretty much useless. – Matt Burland Oct 29 '15 at 15:02
  • You might need to open Kingroot/Kinguser and go to the Root Authorization screen to manually allow ES File Explorer root access. – chester h Oct 30 '15 at 21:25
  • @MattBurland did you try out manually allowing ES? There is also a video tutorial now if that will help. – chester h Nov 4 '15 at 1:57
0

If you have installed a paid app without purchasing it from Google Play Store: go to Google setting → Security → Verify app → disable it.

Alternatively, try to uninstall updates, clear data and let it update again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.