Many of my apps were downloaded from the Amazon AppStore as part of their "Free App of The Day" (henceforth FAoTD) program. This program was recently discontinued in favor of Amazon Underground - an all-encompassing shopping app, similar to any number of their other shopping apps for Android. Since I was not interested in continuing with Android Underground, I uninstalled the Amazon App, AKA Amazon Shopping, AKA Amazon for Android apk.

The next time I tried to run one of the apps from Amazon from the FAoTD, I encountered a dialog and immediate shutdown of the app when acknowledged with the OK button:

Amazon Appstore Required

It looks like you no longer have an Amazon AppStore on your device. Please install an Amazon AppStore and sign in with your username and password to use this app.

  • related: android.stackexchange.com/q/9229/1465 Commented Oct 13, 2015 at 5:08
  • @MatthewRead - sounds like the same thing - I guess the tokens get removed with the AppStore uninstall. In this case, since it was FAoTD installs, my loss is $0, and wouldn't expect Amazon to be generous enough to buy my apps for me elsewhere.
    – wbogacz
    Commented Oct 13, 2015 at 9:59

2 Answers 2


After changing devices, I just started to receive this message as well on certain apps installed from the Amazon Appstore.

The only workaround I've been able to find is that these problematic apps only run without error when the Amazon Appstore is loaded into memory. That is to say I must first open the Amazon Appstore, return to my home screen without ending the process, then I can launch the app I wish to use. If the Amazon Appstore is not running, the app fails to detect that it is installed and refuses to load past the "Amazon Appstore required" message.

This is a frustrating issue and a less than ideal workflow for me, but hopefully this helps others experiencing the same problem. It certainly ensures I won't be buying any apps from the Amazon Appstore again!

  • On my device, Amazon Appstore is nearly impossible to turn off and keep it that way. Do you have an aggressive battery optimizer acting to keep it off? If so, maybe just making that optimizer control for this specific less aggressive?
    – wbogacz
    Commented Nov 15, 2021 at 22:53
  • I just have the standard battery optimization settings for the Amazon Appstore. It does remain open for a good while but it eventually gets purged from memory as the day goes on. I know I can change that to "Don't optimize" setting but the apps which require it aren't mission-critical for me so I've just been getting used to opening it as needed. In any case, I just thought it would be worth documenting in this thread that having it open in the background does seem to help alleviate the problem. Not a true fix, but hopefully this information helps some folks out. Thanks for your input! Commented Nov 17, 2021 at 21:56
  • My Amazon Appstore doesn't expend any effort to stay on, it seems. Commented Sep 28, 2022 at 3:24

The solution is as stated, though it was not easy: re-install Amazon AppStore. Amazon Appstore is not distributed from Google Play any longer (though it was when I first installed it). It must be installed from amazon.com (as a 3rd party app - Settings > Security > Unknown Sources must be enabled), and updated to the latest version - Amazon Underground for the dialog to stop appearing when starting "Free App of The Day" apps. This left the device with an unwanted app with necessary space consumed unnecessarily.

After the installation, I was able to test the correct opening of certain apps I got through the FAoTD program. I tested starting them both ways: from the "Your Apps" list from within Amazon Underground, and outside that environment, directly from the launcher:

  1. 2Do (which had a lot of checklists for Books and Movies I would have lost),
  2. DoggCatcher,
  3. mSecure,
  4. Monument Valley, and, I presume, the re-enabled startup of
  5. Nearly 2 dozen other apps and games.
  • This didn't work for me when I tried it last. Commented Sep 28, 2022 at 3:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .