The voice-to-text feature is very useful, but every once in a while when sending an SMS or email message to a friend, I want to really let loose.

However, Google, in their defense of my virginal eyes, replaces such words with hashes (####) if it recognizes the word at all.

How do I turn off this ####### "feature"?

  • 2
    I am interested to know if this is possible, I haven't found a way. I think you should use #### in the title too :) – Ryan Conrad Aug 18 '11 at 18:01
  • Here's my trouble: it worked on my previous droid razr maxx, but after I got it replaced with another when it got broken, even when I uncheck "block offensive language" or whatever under the voice-text input, it STILL does it. – user39062 Aug 8 '13 at 16:41

There is a checkable/uncheckable option called Block offensive words under SettingsVoice input & outputVoice recognizer settings.

In Android 8.1, that setting is in SettingsSystemLanguages & inputVirtual keyboardGoogle voice typingBlock offensive words

For Samsung phones, the settings are named slightly differently: from the Settings app, try Language & inputVoice search settingsBlock offensive words. This of course only works with the integrated Google voice recognition.

For Android 4.3 (and possibly earlier versions):

SettingsLanguage & inputGoogle voice typing (settings)Block offensive words

For Samsung S8+: SettingsGeneral managementLanguage and inputOn screen keyboardGoogle voice typingBlock offensive words

  • 1
    Bah, you beat me to it! – shambleh Aug 18 '11 at 18:15
  • haha, it's a setting i've also had to find and change ;) – jlehenbauer Aug 18 '11 at 18:16

Settings, Language & Input, Voice Search Settings, Then uncheck "Block offensive words" (thats for Samsung phones)

  • Not only for Samsung, it is for every phone running on Jelly Bean 4.1+. – Matthieu Harlé Jul 18 '13 at 7:51
  • 2
    How is this different than the accepted answer? – ale Jul 18 '13 at 12:43
  • @Al: It's going to get downvoted more! – user5506 Jul 18 '13 at 12:46
  • @AlEverett After this answer was posted, I accepted/improved an edit to the other answer from an anon user adding this information. sabrina, was that you? – Dan Hulme Jul 18 '13 at 13:00

I have a Moto E on Boost Mobile. It's a little different. Settings > Language & Input > Google Keyboard > Text Correction (There is also a setting called Current Keyboard. Make sure to go into Google Keyboard instead.) "Block Offensive Words" switch off, and you can curse like a sailor!

Edit- That didn't change the censored output, but they're right! There's another one. Settings, Lang. & Input, Google Voice Typing, Block Offensive Words switch. This one made the output change. Wonder what the other one is for?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.