12

I have a question about the WiFi battery usage on the Nexus 5. In the first screenshot you see my battery/WiFi usage. The second screenshot shows the battery/WiFi usage for the Nexus 5 of a colleague of mine.

Abnormal behaviour battery Nexus 5Normal behaviour battery Nexus 5

Strangely enough, my WiFi is disabled. Why is this so?

  • Google has an option that it can scan for WiFi networks, even when turned off. – Thomas Vos Oct 13 '15 at 15:16
  • 2
    Okay, but then the next question rises; why does the Nexus 5 of my colleague use 81mAh over 23+ hours and mine w/o using it 1257mAh over a period of 2+ hours? – AMRis Oct 13 '15 at 15:22
7

There is a known issue on Nexus 5/6 with Marshmallow and wifi. This wifi drain has been noted by many users, me included.

http://forum.xda-developers.com/google-nexus-5/help/wifi-plaguing-android-marshmallow-t3220031

  • Yeah I already searched on the internet for other solutions. I came across a few answers that also include to go back to the latest Lollipop (5.1.1.) and OTA the upgrade. A few had already good experiences with this. I will try that. – AMRis Oct 14 '15 at 9:04
  • So today I had finally the time to do the above thing and surprisingly my battery drain over WiFi has stopt immediately. It's even not showing in the list at all, at the moment. My screen is now the 'normal' drainer again. :) – AMRis Oct 20 '15 at 22:46
  • Same here. So weird. – ToYonos Oct 21 '15 at 6:21
5

A few days back I had the same problem and I was able to fix it!

Now all you need to do is go to Settings → Location → options (3 Dots top right corner) → Scanning → Uncheck Wi-Fi Scanning. This is for Marshmallow update.

3

@VenomGT rightly pointed out the 'new feature' which affects the battery.

You might also want to adjust your settings to not use wi-fi when your screen is black/off. To do that, use:

Settings -> Wi-Fi -> Advanced -> Keep Wi-Fi on during sleep.

1

As I have found out, the problem lies in the 'Location' settings. After a while and some reboots, I found out that the Wi-Fi drain suddenly came back. Now I have set the location 'mode' to do the determination as device only.

(Click image to enlarge)

IMG:

And now after about 3 reboots and 3 full charge cycles the Wi-Fi problem is gone.

(Click image to enlarge)

IMG:

Battery by the way is now capable of lasting at least the work hours but after 12 hours I already do need to charge.

Hopefully, this is the final solution that I can give.

  • This should help but sometimes I need wifi for location especially when indoors. – Deqing Mar 6 '16 at 23:23
-1

One reason for this could be the amount of signal/strength of your Wi-Fi as this can have an effect on battery usage.

  • 1
    Could be, but the WiFi is turned off all along. – AMRis Oct 13 '15 at 17:58
  • Right, the only thing I can think of is that i could be a glitch in the update as the Marshmallow has only recently been released. They could update it later. – user3283504 Oct 13 '15 at 18:04
  • And I also thought about that but my colleague was also updated to Marshmallow. So in that case it wouldn't be a glitch in general... – AMRis Oct 13 '15 at 18:24
  • I guess so. does this actually affect the battery life, as it could be that you need to get a new battery for the mobile. – user3283504 Oct 13 '15 at 18:32
-1

SEE MY OTHER ANSWER, THIS ONE ONLY HELPED FOR A FEW DAYS BUT NOT PERMANENTLY

I reverted my Nexus 5 by downloading the lastest 5.1.1 Android Factory image and after 'downgrading' I let the device update OTA to receive the 6.0 update. From this point on my Wi-Fi issue is not occurring anymore.

So my workaround after I upgraded to 6.0 by the factory image and had the Wi-Fi drain issue:

Go to: Factory Images for Nexus 5 and download the latest 5.1.1 (LMY48M)

I did it through a Linux distribution (UbuntuGnome) so my steps were slightly different from the Windows users. Follow these steps for flashing through Windows

Extract the downloaded 'hammerhead-mra58k-factory-52364034.tgz' and also extract the 'image-hammerhead-lmy48m.zip'within the extracted folder; 'hammerhead-lmy48m'

BACKUP ESSENTIAL STUFF FROM THIS POINT
Next steps will erase all settings and data on the Nexus 5

Connect your Nexus 5 to the PC/Laptop where you downloaded the files to and open a terminal or command prompt.

In Terminal:

$ adb reboot bootloader to get your phone into the bootloader screen.

(Sometimes this doesn't work and you can still do it by using the keycombo for the Nexus 5: Turn the device off, then turn it on and immediately hold down Volume Down + Power, as the device begins booting up the Nexus 5 ("hammerhead") will go into fastboot mode.)

When the Nexus 5 is in fastboot mode type in the Terminal:

$ fastboot oem unlock

Beware, if you select yes by selecting it through the Volume+Up button and submit it by clicking the power button, ALL DATA WILL BE ERASED

after the 'oem unlock' is successful, go within the Terminal to the folder where you extracted all the necessary files for the flashing of your Nexus 5.

To flash the files:

hammerhead-lmy48m$ ./flash-all.sh

This took me about 4 minutes until completion and after that the phone rebooted into Android 5.1.1 (Lollipop), almost instantly I got the notification about updating to 6.0 (Marshmallow) and I upgraded immediately without playing or configuring the phone at all.

After all this, no drainage of Wi-Fi anymore and over a period of 7h Wi-Fi 'on' overnight, a battery usage of 26mAh (instead of the 'normal' 700+mAh)

Hopefully this also works for you!

SEE MY OTHER ANSWER, THIS ONE ONLY HELPED FOR A FEW DAYS BUT NOT PERMANENTLY

  • I did just that and it didn't fix my problem at all. I also found that post forum.xda-developers.com/google-nexus-5/general/… so I tried that and I hope it will finally fix my issue ! – Benjamin M. Oct 22 '15 at 8:49
  • Hi, for whats it worth I also tried that solution but made no difference at all. For a moment I thought that it resolved the problem but after 2 hours the Wi-Fi was on top of the ranking again. Now with what I wrote, my Wi-Fi has a consumption of 19mAh over a 5h 36m 6s period of time at this very moment. – AMRis Oct 22 '15 at 9:25
  • Actually, this has fixed my problem and also seems to have fixed the same issue on a colleague's Nexus 5. The battery is still quite poor : currently 84% charged and 9 hours left estimated; but the WiFi is not showing as main battery eater anymore. I would suggest people to first try this solution before wiping their phone ;) – Benjamin M. Oct 23 '15 at 9:41

Not the answer you're looking for? Browse other questions tagged or ask your own question.