2

I've installed CM 12.1 nightly (currently nightly 20151013) and people who call me complains that they have an echo, and they hear them selves.

I already tried the following:

  1. Update Nightly (started at 20151008)
  2. Doing a fresh install clearing all cache.
  3. Flashing the modem with different versions (currently i9500XXUBMG9)
  4. Stop "Ok Google"
  5. Changing the voice recognition to "Basic Google recognition"
  6. Try different ROM (PAC Man)
  7. Edit the build.prop and modify the persist.audio.fluence.voicecall=false

I'm 90% sure that the problem is with the noise cancellation, because when I mute my mic the echo on the other side stop.

This problem did not occur on the stock (4.2.2) I had before moving to CM.

On the stock ROM I had an option to enable/disable the noise cancellation, this feature seems to be missing on CM12.1 ROM.

Do you have any suggestions? Do you know how to enable/disable the noise cancellation?

Update: I've installed the stock rom with Android 5.0.1 and everything works well.

Thanks,

Liron

-1

I have the same problem with the same rom just lower the call volume two notches down from the max and it works fine

  • Thanks for the suggestion, but I already tried it. It did help a bit, but people kept complaining. At the end, I un-rooted the phone and installed Samsung`s 5.0.1 version which works Ok. – Liron Nov 5 '15 at 19:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.