3

I recently updated my phone to Android 5.0. I have been searching for a way to root this device for days and have tried every tool and technique out there including Cf-Auto-Root, Kingo Root, and Towelroot without success.

People say that Towelroot worked on Android versions prior to the latest updated version 5.0. They say that the bootloader is locked and no tool available currently works. Is there any way to get this device rooted or is it impossible to root it?

  • Man, I've been trying to root my SM-900V allllll day now. They even made it impossible to downgrade back to 4.4.2 (where it is possible to root). It must be strictly a Verizon thing because I've found several ways to successfully root different models of the device. Looks like we're out of luck for now. :/ – user134727 Oct 31 '15 at 22:17
  • It's as simple downloading the ArabicTool and these steps: How to us: 1. Enable usb debugging. 2. Accepte notification in your phone to Allow USB debugging authorization. 3. click Read Phone Info 4. click root and wait to comliting root. 5. Install SuperUser form google play. – EcstaticSnow Apr 2 '16 at 15:15
  • @DeliriousSyntax Did you actually try the method you mentioned with SM-N900V 5.0? Because I highly doubt it's that simple. – chaosifier Apr 6 '16 at 11:29
  • @chaosifier Why would you doubt it to be that easy? It's called a one click root method for a reason. One Click Root is actually one of the most popular method to rooting because it is literally that simple. – EcstaticSnow Apr 10 '16 at 20:02
  • 1
    @chaosifier I found it on XDA forum.xda-developers.com/verizon-galaxy-note-3/general/… – EcstaticSnow Apr 20 '16 at 16:38
1

Guys at XDA again did the magic and finally found a way to root this infamous SM-N900V running lollipop 5.0. Here's the entire process in detail:

Follow the steps below to root your device:

  • Install the samsung mobile USB driver. Plug in your note 3 to a PC, a CD drive pops up for few seconds, open it, you'll find the driver for your device there.
  • Now enable developer mode and USB debugging on your device.
  • Download and open the ArabicToolApp.
  • Inside the tool, Select the baseband version of your device, you can find this information under ( Settings > About phone > Baseband version ) of your android device. Note the last 3 characters and select the Version in the Arabic Tool accordingly.
  • Click on Read Phone Info. Now, note the log messages in the Arabic Tool, you should only procced if no warnings are given there.
  • No press ROOT button.

The rooting process should not take more than 6 minutes. If it does, cancel the Arabic Tool and do the following and try again. - Make sure you've restarted your computer after installing the USB drivers. - Use USB 2.0 cable and port.

If during the process, your device gets stuck on the bootscreen, do the following: - Turn off your device, Press (Home + Volume Up + Power) buttons to get into the recovery mode, reset the device from the menu and also clear the cache partition. Now, try restarting your device. If the bootloop still persists, follow the next step.

  • If the above step didn't fix the problem, you will have to reflash your firmware. To do this, download Odin and SM-N900v OF1 firmware from the link provided below.
  • Start Odin
  • Reboot phone in Download Mode by pressing (Home + Volume Down + Power) buttons.
  • Connect phone and wait for the blue sign in Odin.
  • Add the downloaded firmware file to AP/PDA
  • Click the start button and wait for it to show the "Pass" sign. This can take upto 10 minutes.

Once your device starts running normally, make sure you follow the rooting steps given above correctly and try again.

To confirm that your device is rooted, you can press the device info button in the Arabic Tool once again to see the root status or, you could also install RootChecker app from the playstore and see it there.

Once you've confirmed that your device is rooted, install SuperSu and follow the instructions in it to install required binaries.

Guys at XDA recently also found a way to unlock the bootloader of this device. Follow the XDA thread below for more information. Note 3 Verizon Bootloader Unlock

  • If it worked ( which it seems to) please mark it as an answer? It helps tie up loose ends. – Dan Brown Aug 8 '16 at 23:42
  • @DanBrown Just did it. Thanks for reminding. – chaosifier Aug 10 '16 at 7:08

protected by Community Dec 28 '15 at 5:16

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.