10

I'd like to install a specific free android app, which works under different Android smartphones (minimal requirements of Android 4.0):

The freely available app is called PostCard Creator and useful to send Postcards in Switzerland where I live. It works under different physical android smartphones but not with all independent of the android version.

Installation via Google PlayStore: https://play.google.com/store/apps/details?id=ch.post.it.pcc

I've tried different free Android Emulators for a lot of hours under Windows but without success.

  • Android SDK (tried with different virtual devices)
  • Genymotion (tried with different virtual devices)
  • www.manymo.com (App can be installed but not opened)
  • BlueStacks (App can be properly installed from Play Store but not opened)
  • AndY (Play Store notification "Your device is not compatible with this version", Version 4.2.2)
  • Oracle VM VirtualBox Android Version 4.2.2 (app can be installed from Play Store but not opened)
  • YouWave for Android: "There is a problem parsing the package." (I'm pretty sure: The apk is not corrupted.)
  • Droid4X 0.8.5 Beta (Play Store notification "Your device is not compatible with this version", Version 4.2.2)
  • Xamarin Android Player (CPU incompatible)

For http://www.manymo.com I've used the legal APK Downloader (https://chrome.google.com/webstore/detail/apk-downloader/cgihflhdpokeobcfimliamffejfnmfii) to download the APK file which I uploaded here: http://www.file-upload.net/download-10976262/ch.post.it.pcc.apk.html

The app perfectly runs in my physical smartphone with version 4.2.2. Based on an email request, the app doesn't depend on the android version. The developer says, it does not work with all devices. I've also tested the app compatibility online. The result was good.

I would be very glad if someone succeeded to use the app PostCard creator on a Windows plattform. Does someone get it?

(Alternatively, if you also don't succeed with Android emulators, I would be very happy if you know a workable way to emulate the PostCard Creator app file from the Itunes App Store, because it works also on my Iphone for free)


Appendix with adb logcat (created on the 27.10.2015)

  1. Download of the newest version Genymotion 2.5.4 (available since 08.09.2015 with Oracle VM VirtualBox included) here and installation on my Notebook (without physical GPS sensor) under Windows 8.1 Pro N / Intel(R) Core(TM) i3 CPU / 64-Bit OS x64 based processor / in Switzerland with own IP
  2. Click "Add a first device" and select "Google Nexus 4 - 4.4.4 - API 19 - 768x1280"
  3. Download "Genymotion-ARM-Translation_v1.1zip" from here and drop it (in unzipped form) directly to the virtual device. Press OK when asked. Again Press OK when asked. Click Win+R and open path cmd.exe. Navigate to the corresponding folder with cd C:\Programme\Genymobile\Genymotion\tools (must be adapted to your path: If you enter dir you must see adb.exe, then you are in the correct folder.) Write: adb reboot (until virtual device has been restarted)

  4. Download of "gapps-kk-20140606-signed.zip" (needed for 4.4.x) based on here

  5. To install the PlayStore: Drag&Drop the downloaded file (also unzipped) into the virtual device, click OK, wait, click OK, wait, write adb reboot into the console, wait. (Android is upgrading... Optimizing app XX of 22.) After the virtual device restarts, the PlayStore can be found now.

  6. Login with personal Gmail-Account (also created in Switzerland) Update of the Google Plus Service and all automatically installed apps.

  7. Try to install "PostCard Creator" from PlayStore (GPS is enabled, Camera is enabled, Identifiers is not enabled (impossible in the free version)) failed with the message: "Your device isn't compatible with this version." Then I tried drag&drop of the PostCard-File.apk. The symbol "PostCard Creator" is available under the APPS list. But clicking results with the notification: "Unfortunately, PostCard Creator has stopped."

  8. Write adb logcat in the console

There is a long output, so I only get the last lines from cmd.exe console which I uploaded here

  • 1
    Does the app just not launch, or is it failing once installed? – Colin Oct 17 '15 at 0:35
  • 1
    It does not launch. (With physical devices it works very often.) – laminin Oct 17 '15 at 1:21
  • 1
    I tried downloading the app, but it looks to be restricted by country. That could be the issue – Colin Oct 17 '15 at 1:23
  • 1
    Could you use a free VPN with location in Switzerland in order to avoid such restrictions? – laminin Oct 17 '15 at 1:26
  • 1
    Possibly, it is most likely using your Google Play account to determine location as well. A good VPN I know you could use is called TunnelBear. But in order to install through the play store you will need to install google play services on the emulator if it is not installed – Colin Oct 17 '15 at 1:27
8
+25

This can happen for the following reasons:

  1. The emulator presents an x86/MIPS CPU which the app does not support (probably not in your case as the app doesn't seem to require native code).

  2. Google Play Services. The emulator does not have them, in fact no emulator can have them unless they licensed it from Google, and most apps depend on them.

  3. Mobile data as an internet connection is required (maybe not at all in your case).

  4. Location data. VMWare is the only emulator I know that can succesfully passthrough to a physical accelerometer/ GPS hardware on Windows tablets which support them. The app might need location services and will refuse to run if it does not provide the necessary location APIs.

  5. The app developer has made the app actively check whether it is being run on an emulator or not, and the app will not run if it detects that it has been launched on an emulator. See this AE question.

For your case, I suspect either 2 or 4 is the culprit. Try:

  1. Installing Android 4.4 on VMWare Player with a x86-compatible GAPPs package and see if it works (maybe on a Surface Pro, because it has the requisite GPS hardware). The GAPPs packages can be found on XDA threads.

  2. If you use the .iso provided by the android-x86 project, set the VMWare boot mode to BIOS in VM Config.

  3. Once the install completes, put the downloaded GAPPs zip onto a pendrive along with an apk for a file explorer app (I recommend ES File Explorer, that way you can extract the zip directly in the explorer).

  4. Now once the VM boots up, assign the pendrive to the VM from the "Devices" (or similar) option in the menu bar.

  5. Install the file explorer apk from the pendrive (use the built in file-manager) (ensure the "Unknown Sources" option is enabled under security settings).

  6. Then root the VM following this guide.

  7. Finally, extract the GAPPs zip to a convenient location (such that it extracts to /sdcard/) in the VM and follow this guide (use method 2) to install it.

The reason being most phones or other devices with Android from the factory have these Google Apps(GAPPs) preinstalled as the OEMs kicense it from Google, but any custom distribution of Android initially lacks these as their developers either can not or do not license these GAPPs from Google. Emulators fall into the second, custom, category.

Also, location hardware and region restrictions on the app can be the culprit too. The emulator cannot emulate location hardware and/or presents unexpected location or region data to the app, causing it to crash/freeze/whatever.

Edit:

From analyzing the logcat file, I can conclude that the Postcard Creator app actively checks for a touch-capable screen on the device (which any emulator other than the SDK one or Bluestacks/Youwave will fail). In the given case, this is probably what is causing the app to crash. Also, the app is loading a native library, libxwalkcore.so, which is succeeded by a Fatal Signal 11 (SIGSEGV) from the Dalvik VM library, which probably indicates a segment fault (segfault), which force-kills the app process. There is also an error in taking a screenshot of the activity, which is probably related to the one that Android displays for the recent apps, and understandable as the app has crashed.

Also, I think that VMware can passthrough to a touchscreen on a touch-capable device, but again, Android-x86, not being built to run on touch-capable devices exclusively, might lack the necessary drivers to present a touchscreen to apps which require it.

EDIT 2:

I came across this today: ConsoleOS (note that this isn't an emulator, it's rather like running a Linux distro in dual-boot mode on a PC with Windows, with rapid switching (they say as little as 10s) between them).

This claims to be an Android all-in-one package for x86 PCs and tablets which allows for native licensed GAPPs and also is licensed by Google for OEM distribution. This might just cut it. If now your app doesn't run, its probably because it doesn't support the x86 platform. Then, I really have no idea how to go further.

Important

This is a developer focused release and is as such not at all feature complete and buggy. Think of it as an "alpha" ROM. It might refuse to boot or have various other issues. It might make your test PC completely unusable. Do not blame me if this happens, and please heed this warning.

Check this out ("their" comparison to other Android-on-x86 projects):

comparison

Image credits: ConsoleOS Inc.

  • Thank you! I will try it as soon as possible with the VM Ware WorkStation version 12 I get for free from my university. Because I have no Surface Pro, I'm required to try it with my notebook. – laminin Oct 27 '15 at 23:10
  • Now I tried to install android on VMWare Workstation. The installation process will not get finished withouth freezing the android virtual screen (for more than one hour). It looks like this: imgur.com/T3qPcjD I don't know why the installation process interrupts/freezes. Should I now reboot the virtual machine and try if I can load the Google-AppStore Package now? – laminin Oct 30 '15 at 19:35
  • Did you follow the guide? – Tamoghna Chowdhury Oct 31 '15 at 3:46
  • 1
    I have an idea. – Tamoghna Chowdhury Nov 8 '15 at 14:44
  • 1
    Hi Tamoghna Chowdhury. Your "EDIT 2" sounds great! Thank you! I tested it on two computer, unfortunately it doesn't work on my two different computer systems (an empty space is blincking while the PC tries to boot the USB device). Currently Console OS should work properly with one of the listed computer systems here: wiki.console.com.co/w/Devices. If someone has fun to try it, and if PostCard Creator also works, please feel free to tell me if you succeeded. – laminin Nov 15 '15 at 12:46
1

Google recently released an ARC Welder Chrome app, which allows you to run Android apps if you’re on Chrome OS, or using the Chrome web browser.

Look at this Getting Started guide.

How to Use Google’s ARC Welder to Run Android Apps in Chrome

Very General Instructions:

  1. Setup work folder (Once off, only happens at first luanch)

  2. Load the APK

  3. Click Luanch, The apk then should Run

I hope this works for you. Add a comment if you need more info.

  • 1
    Unfortunately it doesn't work. I use Google Chrome 46 (64bit) and started the ARC Welder. I loaded the apk after pressing "Add your APK", but the app doesn't get loaded. After half an hour I close the ARC Welder which still tries to load the apk. – laminin Oct 26 '15 at 13:53
  • 1
    @laminin From your comment in your question above, if you don't have enough disk space to save a logcat, you wont have enough space to run any emulator as they need some space to work in. so my solution would be clearing some space and try again. Because you cant run anything successfully without any free space. – Matt07211 Oct 26 '15 at 22:37
  • 1
    I had approximately 2 GB after successful installation of ARC Welder. So, the disk space had nothing to do with ARC Welder. I deleted my comment concerning disk space above to avoid misconceptions (I've now created 18 GB of free space). – laminin Oct 27 '15 at 21:44
  • 1
    @laminin That problem has now cleared been cleared up, so now you can elimate another cause of the problem. Also just try one more time to download the apk and see if the new version works with any emulators. – Matt07211 Oct 27 '15 at 22:08
  • 1
    see my appendix above (I didn't found any complete file like "adb logcat" generated in my tools folder where also the adb.exe is listed, so I uploaded the part I get from my console (cmd.exe)) – laminin Oct 27 '15 at 23:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.