1

May I ask for your help regarding this frustratingly persistent error that has been plaguing my Android device?

Does anyone know the probable cause why an error 495 pops up whenever I try to update or download an app? I'm currently using a stock Android L 5.1.1 non rooted device with the latest updates installed.

I tried the following steps to resolve the issue but to no avail:

  • Cleared the Cache, Data and uninstalled updates of Google Play Store
  • Cleared Cache and Data of Download Manager
  • Cleared data of Google Play Services Framework
  • Tried installing an app from PC (Play Store accessed in browser)
  • Removed and re-added my Google Account.
  • Factory Reset (thrice already!)

Can someone help me? All my other devices (1 Android L 5.0 and 1 Android 5.1) can download and update apps flawlessly from Google Play Store. They are all on the same Wi-Fi network.

Any help, comment or suggestion is greatly appreciated!

  • You could try to turn on your Location in the Settings and try downloading the apps. If this doesn't work then use a different Google account. Alternatively you can try mobile data or a different Wi-Fi network. – Lucky Oct 18 '15 at 12:06
  • Thanks but I never turn off my Location settings. Regarding Wi-Fi, I've noticed that this particular phone of mine refuses to download in my wireless network but does so when using data or when connected to another wifi. The odd part is that amongst my devices, this is the only one that encounters the error when connected to my wifi. I really don't know what causes this... thanks! – Saudate Oct 25 '15 at 7:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.