0

I am trying to sideload the Android Marshallow OTA on my Nexus 6 using adb sideload "<android marshmallow OTA>.zip", but the console keeps printing out error: closed with no success. I verified that I have enabled USB debugging, but this is still a problem. I have tried running adb usb as well as adb kill-server and adb start-server as well as rebooting the phone to resolve this, but so far, no luck. I have also tried unlock the bootloader, although that did not seem to help.

The phone's Android Build Number is LMY48T (Android Lollipop 5.1.1)

Does anyone have any idea how I can fix this? I am running Windows 10 Pro x64 on the machine on which I am trying to do this.

  • Does adb devices list your device? Proper adb drivers installed? – Manubhargav Oct 18 '15 at 13:41
  • @Manubhargav Yes, adb devices does list the device, and I do have the proper adb drivers installed. – DavidB Oct 18 '15 at 15:50
  • Before you executed adb sideload command, did you explicitly enable sideload option in your recovery? Which recovery are you using? – Firelord Oct 18 '15 at 19:28
  • @Firelord I am using stock recovery. – DavidB Oct 18 '15 at 19:52
  • 1
    @Firelord I feel like an idiot now. I haven't been able to do this because for some reason, my phone would lose its connection to my computer after executing adb devices. Pulling the connection and plugging it back in seems to resolve the problem. To answer the first part of your question, yes, I had selected the sideload option when trying to do this. – DavidB Oct 18 '15 at 20:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.