4

I recently installed cyanogenmod 12.1 (snapshot, 2015-09-01) on my HTC One M8. Following my habits, I tried to activate a silent mode. There was the first problem: CM only has a normal and a (total) silence mode. I was used to normal, silent but vibrating, silent and non-vibrating.

The silent modes on stock android I knew before (and on HTC's android), all made an exception for alarms, you could hear them even though the phone was silent (and I don't mean just vibrating).

What do I have to do to get a silent mode, that allows audible alarms on CM?

3

Since lollipop 5.0 and above, these modes are changed and are accessible via Settings > Sounds > Interruptions.

  1. All Interruptions:
    It is equal to general mode. You get ringtone and notification sounds. And you can set volume for them. When you decrease the volume to minimum, it becomes vibrate only mode. Alarms, all calls and notifications work sound when volume is set, and vibrate (not all) when volume is minimum.
  2. Priority Interruptions
    You get priority notifications. Alarms are always priority interruptions. You can actually tweak this in Settings > Sounds > Interruptions and choose if you want to be interrupted by calls or messages or events and reminders with fine grained tuning to from anyone / contacts list only / starred contact list only. When volume is set to minimum, goes to vibrate only mode as above.
  3. No Interruptions:
    Basically no interruptions. Equal to complete silent mode. You wont get any sound/vibrate for calls or messages or alarms or any other notifications.

So, if you want alarms in silent mode, you may choose Priority Interruptions and tweak it with/without calls/messages/events as per your needs.

1

Inspired by the answer from Bharat G:

Go to SettingsSoundsInterruptions → toggle Never mute alarms.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.